Incorrect Mac os X version error msg

Upon attempting installation I got this message:

You need at least MAC OS X 10.5.0 to install this software.

The problem is I am running Mac OS X 10.13.2 High Sierra.

What could be causing this?

Certainly the fact that you might be using a Cubase version that does not support your used OS. Since you’ re not telling us which Cubase version you are talking about, you’ll probably have to look it up yourself

Hi buddy, I’m having similar problems. Cubase 7 works fine on OSX 10.8.5 (“Snow Leopard” possibly?) But my Mac keeps telling me to update to “High Sierra”. If I do this will my Cubase 7 still work?
Happy researching & let me know how you get on.
Cheers man,