Incorrect Triggers Shown

This continues to be an issue for me where I open a project that looked fine when I saved and closed it, but when reopened, the Triggers may appear to be wrong. When I open the Song/Part Triggers dialog, they are correct there and if I click in that dialog on each on, the main panel is updated to the correct values, but they likely will appear wrong again when I open the project the next day.

It seems like a cosmetic issue because when I click on a Part, the Timeline locates correctly to 3.1.1 in this example, even though the Trigger looks incorrect showing 2.4.1.


To correct the problem, I can click on the Trigger list on each line, collapse the Song, expand it, and then the main Window will appear correct.

It’s a bit random at the moment, Song Two is the problem in this one, but Song 1 was the problem when I first opened the project. I corrected that one, restarted, reopened it, and now Song 2 has the problem.

Please try again with the upcoming version 1.0.30. If the problem still persists thereafter, pls don’t hesitate to let us know, thanks!

Updated to VST Live Pro 1.1 and the error unfortunately still occurs.

Tried to reproduce this quite a while, but to no avail. Created 4 Songs, 3 with 4 Parts each with different trigger times, keep the triggerlist editor open all the time, save, load, change some…all works as expected.
Would you have any receipt how to reproduce this from scratch (new project, add Song…etc), or a project that reveals this? Just the project file (vlsprj) should suffice, no audio or midi etc required. Thank you!

I think i was able to reproduce the error:

  1. Create a new project
  2. Create a song (for example at 120 bpm)
  3. Insert a new track
  4. Create multiple parts
  5. Set triggers for parts
  6. Save project and close
  7. Reopen project
  8. Change Song tempo to 140 BPM (<- I think this is the step that causes the error)
  9. Save project and close
  10. Reopen project
  11. Triggers should be changed/modified

Unfortunately, the system tells me that I am not allowed to upload the file type of the project file.

Edit: All triggers were set to Count 1 in a bar.

Thank you very much. It is much easier to fix a bug with a description like this!
Basically, the bug is purely visual. That is because Part triggers are stored (and restored) in seconds, not beats.
From that point of view, what’s missing is an update of trigger time display in both setlist and trigger list when the tempo is changed. We will fix that with the next version, thanks to your findings.
Now you will probably want to keep the beat positions instead. Triggers were initially designed to be linear time related (as opposed to tempo/beat time), for light control. However from a musical point of view, it makes sense to want the trigger beat positions to stay in place.
We will make this dependent on the display type. If the transport display type is set to beats (as in your case), triggers will be shifted to beat positions as displayed (which will change the seconds position), and vice versa.
Once more, thanks a lot for reporting!

1 Like

You’re welcome :slight_smile: Thank you for the description of the error cause and the perspective that in the future the triggers will be restored depending on the display type in this case.

I am getting a similar issue, but it’ s not merely visual.

When clicking those individual parts, they do not go to the correct sections in the songs; the triggers are off.

I imported a Signature track with the project, which incidentally works well as a visual for where the arranger track splits the parts and proves the parts are not playing where they should.

Some of the parts do not even have play icons next to them; see below:


Pls. check again with the new version. If the problem still persists then pls. report again, thanks!

When is the new version being released?

… it’s online.


Thank you. Just downloaded, installed, and it still does not line up to the triggers, and some still do not show a play symbol:

… you said that you are working with an imported Media Project. Could you please be so kind to export your Cubase project and import the Media Project again. Is it still wrong? If yes, could you please give us access to your Cubase project (*.cpr). We don’t need the media.

Thank you,

Thank you Spork. It is still wrong. How do I go about giving you access to the Cubase project? I believe I attached it to this reply, but let me know if I need to do something else.

No Longer Slaves-01.cpr (845.7 KB)

… thank you for your project, @Mysterite. That helped a lot. We’ve found the problem and fixed it. Next Update.


Thank you so much for your work. This must be frustrating process as you work through issues, but I am looking forward to this being fully functional and I have great expectations for it. So far, besides this issue, I can only think of one other thing that would be useful, and that would be transitions between tracks (continuous play) with possibility to fade, etc.

Thanks again!

Hi @Mysterite,

don’t worry about the time we need to fix bugs.

… I guess you mean transitions between “Songs”? With a FadeOut for Song_1 while Song_2 is preparing and will playing soon?


Yes, exactly. We used a program in a group I was in that allowed you to highlight as many songs as you want (consecutively) to play one after another. Then you can set another set of songs to do the same; multiple times throughout the setlist using different color codes. This allowed for breaks after each set of songs.

… do you remember the name of the application?

Emcee Pro