Input Transformer - where am I going wrong?


I’m attempting to make CC14 messages from my controller (Kenton Control Freak) trigger Aftertouch.

I’ve set it up as the picture below with it set to Local but can’t get it to work with that or Global. I know I’m going wrong somewhere but can’t figure out where.

Any help much appreciated!


ps I’m still happily on Cubase 6.5!


It works to me here. Exactly the same setup.

Thank you for the reply but I was hoping I was doing something stupid!

Tried it in Cubase 8.5 (and with MIDI Monitor open to check what I hoped was incoming) but with the same result. :frowning:


What does the MIDI Monitor shows? Could you send a screenshot, please?

This is Cubase 8.5 with MIDI Monitor and Input Transformer.

You are sending the data at MIDI Channel 1, but in the Input Transformer you set the MIDI Channel is Unequal 1.

Do you want to apply this to MIDI Channel 1 only, or do you want to exclude it?

Ah - I thought you had found it! It should apply to MIDI Channel 1 so I changed it to Equal but sadly it’s made no difference…

Try it without this MIDI Channel line, please.

MIDI Channel line deleted for both Local and Global versions but no change.

Wired… No idea.

Me either but thank you, Martin, for your effort and energy trying to figure this little problem out. My world doesn’t end and music can still be made!

I’m having this same problem. Input Transformer appears totally broken - sometimes it works, sometimes it doesn’t. I have two projects with exactly the same settings, everything is identical. On one, the input transformer is filtering the MIDI messages appropriately, in the other it is doing absolutely nothing. And yes, it is turned on.


Could you share the project, where the Input Transformer doesn’t work, please?

I need to do some template building. Have input transformer bugs been fixed in Cubase 13? I was still running into them with the latest build of 12.