Inputting notes quickly one after the other leads to chord


I got myself a Komplete Kontrol M32 a few days ago, and now that I have a keyboard directly in front of me, productivity is really going up, great! :slight_smile:

There’s one little thing I observed every now and then:
I put the cursor into a bar that already has some notes, activate the caret, hit “L” so the input follows the note values. Now, when I press the keys on the keyboard too fast, sometimes multiple key presses will be pulled together onto a single note, creating a chord. This happens even if I really try to completely release one key before pressing the other (playing it “staccato”).

Of course, Dorico has to decide which MIDI events form a chord and which are separate - just in my case, writing for wind band, one player per staff, creating chords is pretty much never needed.

Is there some threshold setting I can tweak in Dorico to prevent this?
Or is it an issue with my keyboard?

Thanks! :slight_smile:

There’s no threshold you can edit for this (it’s set to 100ms internally). Perhaps you just need to go a shade more slowly!

1 Like

Thanks, Daniel! :slight_smile:

In my experience it’s not the tempo but the unwanted legatissimo that makes Dorico misunderstand the Midi events. So: Inputting notes with a Midi keyboard with locked duration on gives you the chance to train your non legato skills.