Inputting using a midi keyboard

Hi there
Can anyone help me to get this working please? I have a midi keyboard but can’t get dorico to recognise it. The online help video says that a green dot should appear in the corner of the screen to show that midi is being received. I don’t have a green dot, but don’t know how to fix this. I can record into other programs with this keyboard, but not dorico or musescore for some reason.
Thanks!

Check Preferences–Play–Recording–MIDI input devices. Is the device showing on the list? Is it checked?

Seems to be working now, thanks. However, recording in results in complete rubbish so I obviously haven’t worked this out yet!

I have no playback though so I couldn’t hear the metronome which probably didn’t help

I wrote an article on this that you may find helpful. https://www.scoringnotes.com/tips/real-time-midi-recording-in-dorico/