"Insert Silence" adopts incorrect tempo.

I have bars 1-8 at 240bpm, bars 9-16 at 220, bars 16-24 at 240
[Tempo is defined by a tempo track]

I want to add an 8 bar prelude to bars 9-16 at the same 220bpm tempo. If I make the selection range bars 9-16 and use the “insert silence” method it adopts the incorrect 240 tempo of the previous 8 bars. If I move the selection range to the right a bit it adopts the desired tempo but, of course, it splits the existing 8 causing more hassle.
Is there a way of forcing the inserted prelude to adopt the desired 220 bpm?
Thank you.

“Process bars” would be the way to go, unfortunately it is not available in the elements version IIRC.

OK, thanks, but first I need to understand the inconsistency of the Cubase elements version as I have just noted that the required functionality does actually seem to be present in another project.
Referring to the attachments:
Where the step change in tempo is defined by the square dots. To make the step abrupt the upper dot is dragged as far right as it will go.
In the original post’s case [different example with the same problem] both dots can be dragged to the same time ( and so the insert silence presumes the upper tempo.
In an earlier project I can actually get the insert silence to adopt the expected tempo because the upper dot cannot be dragged to the same cursor point ( vs
I cannot see where this dragging inconsistency comes from.
Does anyone know which bit of the project settings defines the ability to drag the upper dot to the exact time location as the lower?
Then I can set the settings to give me what I want.
Thank you