Insert Silence not moving tempo events

Hello, Cubase 8.0.10 is the version i’m using.

I have an issue which I’ve tried to find mentioned on these forums and elsewhere but had no luck…
When using the Insert Silence command in one of my projects, subsequent tempo events are not moving. They are staying at the original bar number.
I have done some experimenting and had some strange results. I tested in a new, empty project.
Test One:

  1. Created project
  2. Added a MIDI track
  3. Drew a MIDI part
  4. Saved project
  5. Created a tempo change at bar 50
  6. Set L locator to 1 and Right Locator to 5
  7. Selected Edit>Range>Insert Silence
  8. Silence was inserted, the MIDI part moved and the tempo event moved to bar 54
  9. Exited without saving.

Test Two:

  1. Reopened this project.
  2. Checked that Insert Silence worked (it did)
    3.Imported a tempo track (.smt) from another project which Insert Silence works correctly on.
  3. Made a note of a tempo event (bar 311 change to 5/4)
  4. Set L and R locators as before and Inserted silence
  5. All audio and MIDI parts moved but the tempo event remained at bar 311.

    What am I doing wrong? I have checked the project settings and the tempo track settings.
    I’ve not had this issue before. Is it a bug in Cubase 8.0.10?
    I have another project in which Insert Silence does not move tempo or signature events no matter how I sneak up on it…
    The world awaits the next work of beauty from Twombley Burwash, and we’re stuck…!



update to Cubase 8.0.30, please. This works to my system, and if I remember correctly, this has been fixed in mean time.

Thank you for the reply Martin. I have upgraded and the behaviour is the same :frowning:


I don’t understand the step 8. Why is it exeted without save? Do you mean, Cubase crashes?

Btw: Are you on Mac or Windows?

Step 8. I just exited without saving. Cubase didn’t crash. I wanted the project to be in the same state for testing the tempo import. Win 7 64

But then this scenario works as expected, right?

Is there a difference in this behavior between Inserting Silence with Tempo events, and Inserting Silence with Time Signature events?

Hi vic_france. The behaviour is the same with both Tempo and Signature events.

Hello Martin -
I wanted to test the insert silence function in a new project, which wouldn’t have been corrupted somehow.
So I created the new project and saved it (no tempo changes) which gave me a project to test a variety of actions on.
I tested inserting silence and it worked as it should.
I didn’t save it at this point - I just exited so that I could test the import of a tempo track on the same project in the same state as the first test.
I imported a tempo track from a working project (where the insert silence behaves as it should) and when I did the “insert silence” it did not move the events, so it did not work as expected.
I have tried inserting silence in a couple of other existing projects. One of them worked properly and the other one did not.
It doesn’t make logical sense to me. The results of the above are not explained by the project settings, and neither are they explained by something in the tempo track itself.
If there was a setting in the project then in my first test (with the newly created project) the Insert Silence function should behave the same with tempo changes manually inserted into the project as it does with tempo changes imported from another project via an .smt file.


So the Insert Silence function doesn’t work in the project, which was imported from MIDI File to you? This also works to me.

Martin, do you mean that when you import a tempo track to a project, the insert silence doesn’t work properly?

No, this works to me. Every scenarios, I tried, works so far.

Weird. I’ll try deleting preferences…

Deleting the preferences folder hasn’t worked either.

I believe I may have solved this. It is possible during the creation of the original project that when I added a VST instrument I may have clicked Yes to assigning a MIDI track. I have re-created my project from scratch, copying audio from the original project but only copying the MIDI notes from the score editor, not the whole file. Everything works properly now…

This is definitely a bug when importing .SMT tempo tracks - can confirm the issue here.

From an empty project, create a bunch of tempo / time sig changes
Export the tempo track to an .SMT
re-Import the .SMT

Range: Insert silence and delete time now have zero effect on your tempo and time signature tracks.

I’m using Nuendo 7.0.30

It’s not moving some automation events either Ian. In 7.5 I had an issue where some insert plugin automation wasn’t moving, and this time in Cubase 8.03 some channel volume automation doesn’t get moved.