Insert the symbol on all staves... crashes Cubase

The manual says (on page 70 - Inserting Clefs, Keys, or Time Signatures)

  • To insert the symbol on all staves, hold down Alt/Opt , and click the position where you want to insert the symbol.

(Cubase_Pro_Score_12_Score_Layout_and_Printing_en.pdf - WebHelp version)

Inserting a clef on multiple staves using the Option key doesn’t work. Also, if I try the same thing on other grand staves, Cubase crashes.

Steps to reproduce the crash:

  1. Do the following:
    a) In an empty project, add 2 MIDI tracks.
    b) Draw on each a three measure MIDI part, starting from bar 1.
    c) Select both MIDI parts and open the score editor.
    d) Switch to Page View (Scores > Page View).
    e) Click on the Split button (scissors button), located on the Score Editor toolbar.
    f) Click on the right hand barline of the second measure.
    Or… download this cpr.
    Alin89c - Cubase 12.0.60 project.cpr (107.3 KB)

  2. Click the Clef button (Left zone > “Clefs etc.” category).

  3. Click where the red “X” is (holding down the option key).
    Note: The point is to click at the position (not necessarily on the treble clef)

  4. Choose a different clef, or simply hit “ok” two times.

Result: Cubase crashes.

Crash file (when I click “ok” two times):
Cubase 12-2023-05-21-195119.ips (70.2 KB)

If your cpr is needed, it’s not a bug. Post a repro please, as has been requested, or wait for someone willing to do this.

1 Like

I thought it would be easier for other users to see if the bug is really there. Anyway, I edited the topic’s first post. Hope I didn’t miss anything.

@Martin.Jirsak , I know you use macOS. Would you please check to see if this is a real bug? Thank you.

Not sure what you’re trying to say. Your repro doesn’t match the manual entry you linked.

It’s not necessary to select the tool, and double click the clef.

I tried a few variations of the repro though, and all worked fine.

By the way, did you rule out corrupt prefs before testing?

You’re right I should’ve said “click”, not “double-click” at step 3.

Yes, but in order to reproduce the crash, selecting the tool is necessary. It was though a mistake from my part. I should’ve said “click”, not “double-click”.
By the way, Alt/Opt + double clicking the clef also doesn’t work. I reported this here.

Then it might be a macOS bug, or a macOS OpenCore bug.

What I tried:
1. I activated the default profile (in Edit > Profile Manager…)
2. I started Cubase in safe mode (with “Disable program preferences” checked)

1 Like

Looks like.

1 Like


It didn’t crash before, but now it crashes. It’s necessary to hold the Opt down, when clicking to the clef. Why do you hold Opt, please?

Btw, very nice structured report, thank you!

Reported to Steinberg. Thank you.

1 Like

Well, I would expect to get the same clef (or key signature) on all staves, according to the referenced section of the manual (see the PDF/WebHelp manual reference in the first post).

Here’s how Cubase Pro 8 behaves (GIF made on Yosemite 10.10.3)—proof that it worked.

The same behavior can be observed in Cubase 12 also (but only if the first grand staff is edited; otherwise—as I’ve said in the first post—Cubase crashes). Would’ve been nice to see in the text that the user must adjust the clef/key setting multiple times (before pressing OK).

1 Like