Inserting one flow into another in another project...

How can I do that?
They are in different projects. What his the safest way? By the system track? Do I have be aware of anything due to odd meter ?
Thanx for an advice ,


If it’s a short flow you can just copy it over, otherwise export the flow you want to insert, then import it, and you should be guaranteed of retaining all the info.

  1. File/Export/Flows … select the flow you want to export
  2. File/Import/Flows … select the flow you just exported for import

Just be aware that the flow will take on the Engraving and Layout options of the file you are importing the flow into. Notation options are Flow based so they should stay the same.

Thanx a lot.
Its a quiet short flow. How do I say the flow where it should be exported to f e to ba r 8?

Is it possible to do it by the system track? I select my choice and tried to copy it… but that does not seem to work…

And there is another problem… when I try condo C… the bars seem not to be inserted nut replacing some old bars?
The piece before Strats with a 7/4 now it starts with a 2/4?

Whats wrong?

It s a real strange behavior. the piece has 97 bars and after copying 7 bars into the beginning it has 99 bars? Is that a bug?
Really weird.

How can I dop that? I was a imprecise in the other post.
I want the bars after the inserting being removed not overwritten.


Without seeing the two flows it’s impossible to know what’s going on. It could be that you’re copying a passage that doesn’t have a time signature at the start, in which case no time signature will be copied (and the pasted music will take on the preceding time signature in the destination flow). It could be that you don’t have Insert mode on when you should. It could be that there are explicit bar number changes in either the source or destination flows.

It could be a bug, of course, but there are plenty of possible logical explanations for why this isn’t working quite the way you’re expecting it to.

I’ve merged your new thread into your existing one, since this is all a single issue.

I would suggest you start by deleting the bars in the original flow that you do not want to remain after you copy and paste. You can do this using the system track, or by selecting the first note or rest in the first bar you want to remove, then typing Shift+B to open the popover, then enter e.g. -999 to delete the 999 following bars. (If there aren’t 999 bars, Dorico will just delete to the end of the flow.)

Then select the material to be copied, which indeed does make sense to do via the system track. Highlight the bars in the system track, then click the rectangular selection button to select all the music in the bars, then type Command-C.

Finally, show the caret at the end of the destination flow, at the point at which you deleted the remaining bars, and position the caret in the top staff that the music should be pasted into. Then type Command-V to paste.

Thanx for your answers. But till know I don’t manage:

I have a piece with 99 bars.
and I have 4 small pieces (7 bars , 8 bars…). These small pieces are xml imports from a sibelius session.
The first of the small pieces is just 7bars long, there ar no other bars in that flow and project.
these should be placed in the beginning of 99 bar piece.
So I select these 7 bars by using the system track, hit cmd c.

Than changing to the 99 bar piece. Here tried different thing: insert mode on the “1” of the 1. bar: than cmd v
or highlighting the first bar number. than cmd v…

but all that always leads to the problem, that the existing bars are not removed but overwritten.

The same things happen when I try to copy music into the middle of the 99 bar -piece.

I could insert the bars manually and than copy the notes… but that takes much longer time.

Any other ideas?

Thank you

In the destination flow, select the barline where you’re going to paste, then type Shift-B 7 Enter. Then copy and paste the bars at this barline with Insert mode turned off.

Thanx for your patience… but no. The result ist that there are 111 bars now.
99+7=111…I dont know what is going wrong. But I thought it is sth simple?

Hm…how can I solve this? Thanx again

Ah right, I think I see what you mean - your 99-bar piece contains existing music (not just empty bars) and you want to add/insert these extra portions of music to the 99-bar piece (meaning it ends up longer than 99 bars?)

If that’s right, I would probably recommend adding the bars to the 99-bar piece manually. Insert mode works per-voice, so if you’re copying lots of staves at the same time, it might be safer to create the ‘space’ first by adding the right number of bars (with the right number of beats, so make sure the time signature is right too) where you want to copy your extra small pieces and then copy them in.

In Dorico, if you copy something at a position, Dorico copies it at that position - it won’t automatically push material later to preserve it unless Insert mode is active, and Insert mode only works for individual voices - it won’t apply to all voices on a single staff. Remember also that Dorico ‘thinks’ in rhythmic beats, not bars, so when adding bars etc, pay attention to the number of beats in them according to the current time signature. If you copy more material than will fit into the added bars, it will either overwrite material in the following bars or, if Insert mode was active, push a single voice backwards

(When you copied before and lost your 7/4 time signature, that was because the material you were copying had a time signature at the beginning I imagine, which overwrote the 7/4 in the destination piece. If you don’t want to copy the time signature, make sure it’s not selected before you copy.)

I hope this is helpful - it’s a bit hard to imagine what you’re describing in the abstract! If you’re still struggling, perhaps share the project with the snippets you want to insert, or at the very least some pictures?

Sorry if I can not explain correctly…
But yes… I want the original bar number 1 in the 99 bar piece becoming bar
Number 8. After having inserted 7 bars in the beginning…
But ok… I will try do that manually now.

So… never-ending…I am doing that now by “creating” new bars, before than copying the notes. But when I change the time signature Dorico keeps the number of quarter notes .

So f e when I have a 7/4 bar and want to change it into 3/4 , Dorico doesn’t do this, it creates one 3/4 and one 4/4.

Which again ruins all the other bars after this point…I can change this manually, but is this really the wanted behavior of the program??

Thank you

Dorico doesn’t add beats when you change the time signature unless Insert mode is active. This is so the positions of notes relative to each other are kept, and essentially the barlines just move around the notes (rather than adding/deleting notes or rests at the end of every bar)

When changing the time signature in existing music, I’d recommend inputting a time signature where you want the change to end - i.e. if you have 7/4 but want to change the first 4 bars to 3/4, input a 7/4 time signature again at the start of bar 5. This “fixes” the time signature there. You can then change the time signature earlier and it won’t affect past your new 7/4 time signature in bar 5.

If you change the time signature to one that has fewer beats, Dorico will keep all your beats so you might need to delete some bars afterwards.