Inspector Bank/Program change versus Ext. Synth. in sequencer mode

Hello Forum,

Still fighting w/ Cubase 10.5 studio setup prior making music. I’m mostly done creating my template but I’m facing to new probably basic tuning which doesn’t work as expected.

Setup is 3 Korg external MIDI synth. in sequencer mode hooked via MIDI and USB/MIDI, I’m using external clocking source on all of them. I use a main keyboard to play MIDI through and control per track all these synth. I originally faced to the program patch name issue requiring .xml file beside the 01W which coincidentally have one pre defined configuration native w/ Cubase. So I gave up w/ program names and started working w/ Inspector bank and program number instead (following the -1 rule). That’s fine.

The actual problem is something I do not understand, I searched here for solution but I’m afraid I have to post a new thread ! Changing program in inspector work like a charm per MIDI channel on external synth. but when starting to play, the program on the targeted synth./MIDI/Channel keep being reset ed to it’s default value (sequencer default template one)! Originally enough when play from main keyboard after a stop the inspector program is back ! Honestly I poke around on both external synth., clock synchronization settings, edited MIDI event, etc. and I couldn’t find any reason for this behavior. There must be one I missed! So I’m asking here perhaps this will be obvious for some?

Many thanks in anticipation for your responses.



Isn’t the Program Change simply written in the MIDI Track?

Hi Martin,

Thanks for this but no there is nothing in the track (verified w/List editor). This happen to both Karma and Kronos (I haven’t checked yet the 01W) when using external Synch.
I wished someone had a working solution but let’s wait…


PS: I already went on Korg forums for this but couldn’t find any answer beside the nasty comment about the Kronos editor not being 64 bits which prevent usage as a VSt w/ Cubase Pro (Well S/W after all…)


Could your share the project, please?

Hello Martin,

I just found my working solution !
I still attach the template just in case (

The solution is to for Kronos uncheck Receive Ext. Realtime Commands in Global view > MIDI tab. For Karma same setting under Global > MIDI uncheck RT box!

A least now synths. follow inspector