Instaling GA3 to Win7 64-bit

Could someone help me installing Groove Agent 3 to win7 64-bit PC. I have GA1-cd and upgrade from GA1 to GA 3. I have GA3 licence in Syncrosoft.

If I try to install GA1: “please install GA from the original cd-rom”
If I try to install GA3 uppgrade: “can’t find GA1”

What to do? I know that installation should be bossible because I have done it to another Win 7 64-bit computer, but I can’t remember how.


It’s been a while since I performed this action, but if I recall correctly I simply copied the installation CD directly to a folder on my HD and initiated the install from there.

Hi guys,

please send a download request for GA3 to:

We will send you a new download- link for the GA3- ISO.

Please don’t forget your USB- licenser number with the Groove Agent 3 license on it.

Hi… I am having a similar problem, i.e. when I try to install GrooveAgent (original version) from original CDROM on Windows 7 on Bootcamp partition on MacBook Pro, it goes through half the process and then says, “Please install from original CDROM.” Nothing I do seems to make any difference.

Can somebody here please help me with this? Steinberg person perhaps? Thanks! :slight_smile:


If you have a dual layer dvd drive, try using an external cd drive or older dvd drive. I found that worked perfect.
Although, when I tried to install Groove agent 2 update…it starts fine, but then tells me that the program did not install correctly becuase there are other processes currently running. I had the same problem with virtual guitartist and the elctric edition. Althought there, both the update and the version one installed properly. Go figure!

Windows 7, dual quad core amd, 8 gig ram, asus N12319 mb, quatro graphics card, dual 12,500rpm sata drives 600 gig ea. Cubase 7, trilogy, omnisphere, virtual bassist, virtual guitarist, Komplete 7, Amplitude, Guitar Rig 3, Halion 3, Sampletank

hum… I… heee, how come I have cubase 7 with GA-ONE?? How do I get the GA3 install if I didn’t even used a license key or anything…? Just started using GA and wondered if I was using the latest version and found out I’m not.