Installation of GA 5 not possible on MacOS 10.13.6 High Sierra

Hi,

I’m running MacOS 10.13.6 (High Sierra). According to the Steinberg download page Groove Agent 5.1.10 should run on even older 10.12 systems. But the installer quits saying I need “at least 10.14”.

Does anyone know how to install or where to get an older installer? Thanks!