Installation problems Microsoft Visual C++ 2015-2019

Hi

I’ve been having serious installation issues with Dorico Elements 3.5 on three out of four of my PCs. It’s a little tricky and complex to explain but it seems to have something to do with the Microsoft Visual C++ 2015-2019 Redistributable x64 package the software is trying to install. That part of it fails to install, with a pop-up window asking me to locate a data package that does not in fact exist! I’ve had this message before while installing Cubase 10.5 and the demo of Dorico Elements v3. In those instances I just clicked cancel on the search attempt and the softwares actually installed successfully, or seemed to. This time however, something has changed. Dorico Elements 3.5 does not install properly and refuses to run at all on startup. Popups appear saying that a couple of .dlls are missing, etc. Kaput. No start.

I’ve searched on the net and this problem seems to occur with various other softwares. It might have something to do with leftover Visual C++ items in the registry. Some advice was to find and uninstall those entries. I tried that but they refused to go - the popup asking for the non-existent data package appeared again. End of story! I’m stuck. I’m also scared to update Cubase 10.5 in case something similar happens and I get a bricked DAW. Disaster if that happens!

I HAVE managed to install Dorico Elements 3.5 as a test on my laptop, which is a fairly clean machine, but it’s not my music workstation. I have to use Dorico on my music PCs and it’s just not working.

Is there anything I can do to get around this problem? Advice would warmly appreciated.

Thanks
Heath

What if you get the Microsoft Visual C++ 2015-2019 Redistributable x64 package from the Microsoft website and run that installer, what does it say then on your computers?

Tell us exactly WHICH dlls it says are missing, and somebody might be able to help.

MS visual C++ redistributables grow like weeds. I just checked and I have 15 different versions of them installed on my PC! Thankfully, they are not very big so there is no point trying to get rid of the ones that aren’t being used any more.

Thanks for coming back. I’ve redone the process and taken snapshot of the results in chronological order. Snap 06 below is the result of trying to update the Visual C++ 2015-2019 with the file downloaded from Microsoft. I hope these snaps give an insight into the issue. Any feedback would be great.

Thanks
Heath



and these…
04 orico - start up system error  window 1.jpg
05 dorico - start up system error window 2.jpg

Sorry the snaps appear here in reverse order. It seems to be a quirk of the message board.

I just wanted to propose to install the eLicenser Control Center (it’s needed by Dorico anyway). That eLCC also install the Redistributable package. Then I saw in the description that also the MS .Net 4.0 Framework is required. Is that one installed on your system? You can download it from https://dotnet.microsoft.com/download/dotnet-framework/net40

Thanks. I just tried it but the installation detected that it was already on my system and so wouldn’t proceed.

eLCC is indeed installed on all of my computers and appears to be be running normally.

One other thing to try is run the system file integrity checker. Start an Administrator command prompt and type ‘sfc /scannow’. This will check the system files are correct and missing files will be downloaded directly from Microsoft.

Thanks. I’ll try it tomorrow and report back if it works.