Installer crashing.

When I try to install AI 10, the installer crashes every time. I’ve tried running it as administrator but that makes no difference. I read on the forums that installing and activating Microsoft .net framework 4.7.2 would do the trick. Well, not for me, the installer still crashes in exactly the same way.
I’ve also downloaded the available AI 10 update, and THAT installer worked just fine, strangely enough.

I have emailed the Steinberg support, but while I wait for them to answer I thought I’d ask here if anyone has the solution to my problem.

My computer’s OS is Windows 10.

Thanks in advance.


Do you use the Full Installer? Do you know when does it crash? What’s the last you can see in the screen?


I read that you could try unpacking the file with an external unpacker rather than the one that’s included in Windows 10. So I downloaded WinRar and it worked! The installer installed Cubase without any issues whatsoever! :laughing:

I finally solved the problem of Cubuse Pro 11 installer with the solution you gave!! Thank you so much!! :smiley: