Instrument Change: Condensing only works for 2nd instrument after there is notes written in the part

Hi,

I have read in some older posts in the forum (from over a year ago) that condensing only works with the first instrument for a player with multiple instruments. That is not the case for me on Dorico 5.1.3 so not sure if the limitation has been addressed but I am facing some issues. So please bear with me:

I have 2 flute players. 2nd player doubles as piccolo.

  • Player 1: Flute
  • Player 2: Flute + Piccolo

The piece starts with the second player, playing the piccolo.
Half way through the piece, there is an instrument change to flute.

After this change, Dorico does not start condensing flute 1 and flute 2 parts until there is at least a music note written in the flute 2 part. So basically I am left with several pages of empty staves of flute 2 since it does not combine with flute 1. (I need to give time to the player to change instrument)
After flute 2 starts playing (meaning there are notes written in the part), the condensing starts working fine.

Is there a workaround or any way to fix this? This sounds like a bug or limitation.
(I have also tried manual condensing but that does not work either and wipes out flute 1 part.)

Condensing does NOT work before there are any notes written for the flute 2 part (hence the empty staff)

Condensing works after flute 2 part has notes in it

Config:
Dorico 5.1.32
macOS Sonoma 14.2.1

One possible workaround is to create a new notehead set using a quarter (crotchet) rest as the notehead for a quarter note. In galley view on beat three of bar 88, enter a quarter note on the middle staff line for Flute II and change its notehead to use the new notehead set. In engrave mode, select the fake quarter rest, suppress its playback and hide its stem. Select the instrument change label above the fake rest and set its custom text to a space. Finally, use staff text to provide the instrument change warning and label where they should appear.

1 Like

I have a feeling that (in Layout Options) simply setting Instrument Changes to go straight after the last note rather than at the first note should fix this problem.

1 Like

If all else fails, one can manually hide the extra staff: just make sure to manually make it visible again before the Flute starts playing.

This is what I am doing currently as a work around.
The only issue is that the staff label only shows Flute I. Ideally I want it to show Flute I & II without much hacking

Here is a simpler workaround: Use three single players for the first flute, second flute and piccolo. When the piccolo is playing in the score layout, add a condensing change to disable condensing of the flutes and hide the second flute staff. When the piccolo is not playing in the score layout, reset condensing of the flutes and hide the piccolo staff. Add the second flute and piccolo to the same part layout, use system breaks if necessary to ensure both instruments are not playing in the same system, and hide empty staves in all systems. Use staff text to provide instrument change warnings and labels where needed.

2 Likes

The limitation has not been addressed — that would be quite a significant change!
Try to condense both Bb clarinets and A clarinets held by only two players, and you’ll see that only one set of clarinets will condense.
Here, the piccolo doesn’t need to condense with any other instrument so it looks as though it’s working.

1 Like

I think you are misunderstanding the issue here. The issue is not piccolo not condensing with flute. That would be wrong, as it would be wrong if Clarinet in A and Bb were to be condensed.
The issue here is after instrument change to Flute, Flute I and II should condense but it does not.

That’s not how it works, @Janus.

It’s entirely to do with where the instrument change from Picc to Flute happens. There’s a Layout Option for whether instrument changes should take place immediately following the last note in the old instrument or the first note in the new instrument.

There’s also a fudge that hasn’t been mentioned in this thread, which is that if you add a Chord Symbol Region to the new instrument you’ll force that instrument to show/switch (try it before telling me I’m talking nonsense). The side-effects are that any multibar rest at that location will be split by the Chord Symbol Region, and the instrument change warning and/or announcement will be in the wrong place and will need either dragging in Engrave mode or replacing with appropriately styled Shift-X text.

3 Likes