Instrument in Inspector NOT Updating After New Patch Load (Komplete)

Hi, I’m using some old tracks to set up new ones more quickly… Problem is that the old track name seems to stick and not update.
The screenshot attached shows the problem where the red arrows are pointing: the Instrument panel in the Inspector AND the name shown at top of the VSTi window (in this case Komplete Kontrol) are NOT updating - they should be showing GP01 - Natural Forces instead of Prism (REAKTOR).

Can someone help? Maybe I’m not doing something right? Or maybe this is a bug?


My expectation is, Reaktor doesn’t send this information up to the host, so Cubase doesn’t change the name. I would ask at NI forum.

Hi Martin, it has nothing to do with Reaktor. The same thing was happening with Ethereal Earth (I havent tested or noted all instruments it happens with)
I also noticed that in some instances it CAN upodate itself if I click the gear cog icon, disable Instrument, and then re-enable it.
This works for some instances where it is not refreshed automatically by Cubase.


Ethereal Earth is also Native Instrument, so the very same manufacturer.

I suspect Martin’s assumption is correct. Because we are talking about VSTi-s that are all loaded into a Komplete Control instance (which is basically a wrapper for all the NI-Instruments).

Oh ok - so maybe the issue only exists when trying to replace a VSTi manufactured by NI (because there doesn’t seem to be issues replacing with VSTi manufactured by other companies even if loaded inside KK wrapper). However, I would add to this that the disable/enable instrument hack is sometimes needed for the non-NI instruments. That does seem like a little bug.