Instrument Library Issues (GASE Kit troubles)


I’ve recently been having a lot of issues with dorico, namely the playback of certain instruments that are a part of GASE kits (the ones that come with Dorico 5 Pro).

In GASE, the hi-hat foot pedal does not playback. Not sure why this is. I tried looking for the percussion mappings for these kits, but I couldn’t find them anywhere in the documentation. As far as I am aware, the hi-hat pedal sample exists because I can play it in GASE, it just does not play back when written in the staff. In my playback template, I have one of the Halion + GASE endpoints set to “auto” with overrides for Drumset (full) and Drumset (basic)

It also seems like Dorico has been growing slower and slower as I’ve used it over the past year. Perhaps due to the instrument library? I did just upgrade to an AMD 5600x3D, maybe it’s a ram bottleneck? I seem to have a bunch of instruments and techniques that are not present in this project. This is a new project, created from the “Big Band” template in dorico, and then modified with my own engraving settings, instrument names, etc. Not too much added, in fact, I only added the things that are necessary for this project, and tried to remove as much “bloat” as I was able to do.

Any help on this is much appreciated!

library clutter example.dorico (587.2 KB)

I was able to solve this myself - It doesn’t seem to matter which “Hi-Hat (pedal)” instrument (since i have 5-6 with the same name in the percussion map dialog that appear) I had in the kit - It was not self-assigning that instrument in play mode to GASE. I just had to open the drumset drop-down in play mode, and assign the instrument to GASE in the routing drop-down, as it was unassigned.