Instrument numbering on condensed stave.

I found Engraving Options->Condensing->Separator between Player Numbers
Changing it to space and clicking Apply and Close had no effect at all. Also I have no period after the last number despite the setting there.
Finally, what I’d really like is “Trombones 1-3” for example. Any way to achieve that?
Thanks in advance.

There’s no way to show a range of players separated with a dash at the moment, but it’s something that has been requested.

The ‘Separator between player numbers’ option works as expected for me. Please attach a minimal project that demonstrates the problem.

I started preparing the project, then I realized that setting probably applies to player labels above the staff, not as part of the staff labels. So if I understand correctly my condensed staff label is fixed at Flute 1.2, and not editable even in Engrave mode.

No, the setting applies to both staff labels and player labels. You can also edit the text of player labels by selecting them in Engrave mode and then using the Properties panel.