Interchangeable time signature

In Chorale settings you can often find interchangeable time signatures without seperators. I couldn’t figure out a way to enter the time signatures without a seperator. I always have to go to Engrave mode and change the seperator there.
If I than go back to Write mode ans select the time signature I will be shown a combination, which I can’t enter directly.


  • enter “2/4 - 3/4” into the popover
  • go to Engrave mode and change the separator to ’ ’
  • go back to Write mode an open the popover again, by selecting the time signature
  • The popover shows “2/4 3” which doesn’t give me any result, if I enter this directly.

Would be nice, if one could enter an interchangeable time signature without a separator directly. (at least for me …)

You can enter “2/4 + 3/4” for alternating meters, if I’m understanding what you want.

Thank you, Dan, but I don’t want an alternating time signature.

Ok, I’m not clear on what you want. You could enter “2/4|3/4” and set the dash barline length to zero in Engraving Options.

If that’s not what you mean, can you post a screenshot?

Sorry, Dan, but I also don’t want an aggregate time signature. Do you know the difference between simple, aggregate, additive and interchangeable time signatures? I do and my question is not how to get the correct result. (If you follow my steps above, you will get the correct result too). I only ask for a direct way to input an interchangeable time signature without a separator into the popover.

Apparently not. But now I do.

According to the documentation, you can set a global value for the separator. That’s probably where you would input your space character, just once, and set as default.

Here’s a typical exampleof an interchangeable time signature without a separator:

See above. You can change the global value for the separator character that you want.

Engraving Options–Time Signatures–Design–set character for separator.

Ah, that’s true. I can change the global value for the separator in the Engraving options. But I still can’t figure out a way to enter it directly. I must be missing something obvious …

Except that doesn’t seem to work. There’s still no way of entering an interchangeable time signature without the “separator” property becoming switched on.

Normally I change the property to ‘space’:
Oh, Pianoleo jumped in first …

Yeah, you already said that. By the way, you don’t need to be in Engrave mode for that; you just need the Properties Panel to be open. Write mode works fine.

Thanks for your help, Dan and Pianoleo. I still don’t understand, why I can set a global value, but can’t get the desired result immediately and the values, that the popover shows after changing the property doesn’t look right at all. Perhaps Daniel can comment on this, if it is not too unimportant.

This is definitely a bug… If I type 2/4 / 6/8 and untick the Separator in Properties then the slash disappears according to settings in Engrave > Time Signatures > Design, but any new Time Signature inputted will have the Separator enabled by default, thus ignoring the Global Properties of Engrave > Design.

At the very least, you can easily switch it off by binding a key command to:


in your keycommands json file.

There is no way to enter it directly because of the complications of parsing time signatures separated only by spaces in the Shift+M popover.

Could I suggest that another unused key could be implemented to take the place of a space? ’ or * or whatever.