Interface Issue

I am a rookie who used to use Cubase 5 cluelessly. I have since gotten Cubase LE AI Elements 10.5 and recently my 18 year old interface died. I purchased a Behringer UMC202hd. This thing appartently goes up to 192k. The interface came with recording software and it works fine with that but with Cubase it is not registering.

I have downloaded the windows 10 drivers from Behringer (additionally my windows 10 laptop instantly downloaded drivers when plugged in). I have downloaded asio4all and it still wont find it. Cubase does not see any specialized drivers.

I have tried setting the project to 24 bit/ 192k.

I am out of ideas.

HELP please…

try downloading the latest driver for U-PHORIA interfaces
search for “UMC Driver 4.59.0”

Hi and welcome,

What options can you see in the Studio > Studio Setup > VST Audio System > Asio Driver, please?

Actually I redownloaded the UMC driver and it showed up last night however I am still not getting signal from it.

I am out and about at the moment but I will respond :slight_smile: with your requested info later

Hi,

So can you see the driver in Cubase now? Did you select it? What is set in the Studio > Audio Connections > Outputs?

Greetings,

It shows the UMC driver and out1 and out2 as the inputs under studio…outputs. I am also getting a signal now… I am so confused but it appears to be fixing itself so go figure. It has all worked out now, maybe it was Windows being Windows… Thanks for letting me go neurotic.