Intermittent MIDI keyboard issue

I’m having a wierd issue between my MIDI keyboard and Cubase Pro 11. I use a Roland FP10 with a MIDI/usb connection to my desktop. In the past, it has worked fine, no problems. But for the past week or so, when I open Cubase, create an Instrument track using a Halion Sonic SE instrument (which I would then be able to play on my Roland), it doesn’t work. When I check my studio set-up in Cubase, it still detects the Roland as my MIDI input, it just won’t let me play the MIDI instrument, though I can still play it with the on-screen keyboard. What is more infuriating is that this problem is intermittent. It happens once every two times I open it up to try.
Does anyone have any ideas on what this could be? I’m relatively certain it is not a cable issue, as I ordered a second one and the problem occurs with both. Is it a Cubase issue, might it be an installation issue, is it a keyboard issue?
I would really appreciate any help or advice you have.
Thank you.

Hi and welcome,

Make sure the MIDI Input is set to All MIDI Inputs, or specifically to your MIDI Keyboard, please. Make sure, there is no Input Transformer involved, please.

Can you see the incoming MIDI Messages in HALion Sonic SE? Can you see the meters in HALion Sonic SE? Can you see the meters on the track in Cubase?

Hi and thanks for answering!

As far as I can tell, my MIDI input is set to my Roland keyboard. At least, it appears that way in studio setup. And I have no Input Transformer involved.
When it works, I do see the meters when I play the keys. But more often, I don’t. I select the instrument in HALion Sonic, and I can play that instrument on HALion, but when I play my Roland, which is indicated as my MIDI input, there is nothing.


Can you see any differences when it works and when it doesn’t work, please?

I’ve tried to notice any differences but I can’t find anything. Or at least, I haven’t noticed any. I thought it might have been a driver issue, so I made sure everything was updated in my computer, especially for my Roland and my usb ports. And after doing that, it worked for a while. But it just started up again. Appearing in my Studio Setup as my MIDI input, but somehow just not sending anything over.

This happens to me too quite often, I find closing and re-starting Cubase fixes it.