Invalid Project file 8.0.20

Hi,
I’ve searched in the forums couldn’t find a similar post…

Lately when I load a project file I started to see this error popup occasionally, which says "Invalid Project file ".
I don’t remember seeing this as often like now before 8.0.20.
This morning, I rebooted the PC, opened the project, suffix-increment-saved to a new version, made changes, hit Ctrl-S frequently. And just have lost an hour of work again (this time somehow with no .bak, no way to salvage even an interim work). Finally thought of posting here for advices.

Not completely sure about the repro condition, but this is possibly occurring before or after Cubase detects some internal errors and advises to quit immediately. (sorry I don’t recollect the exact error messages)
I didn’t save anything at this point, just quit Cubase and rebooted. But it seems the save I did some minutes before the warning had already corrupted the project file.

Rebooted the PC, tried to load the failed project a few times but sill getting the same error. The old project file that I saved a day before is still OK.

I don’t know if the size matters, but just in case it does, the size of the project is approx 32MB, with just less than 80 tracks, including approx 50 instrument tracks, some special tracks (a marker track, a chord track, an arranger track etc.), some audio tracks and FX/group tracks. Each may include 10-ish track versions.

Some other file corruptions were really quiz to me, I saved without an issue but at a later date I get the invalid project file error.

The popup shows up at the very beginning of the project loading, in no time. It feels like Cubase detected some header corruption, or some kind of sanity check failure (such as file length check or checksum mismatch).
Well, I’m still hoping some quick header tweak can save the content.

Please help!

Just happened again. Tried to open the project file that I saved yesterday. C8 complains that’s an “Invalid Project file”, immediately stops loading the project. Providing no options, no hints to recover.

I really hope I don’t have to hit this again…

The project file is probably corrupted. How about opening the latest .bak (backup) file. Bakup files should be locted in the project folder and you will probably have to change .bak to .cpr to open it.

Regards :sunglasses:

Thanks Prock for the reply - yes, when .bak is available, I agree that’s an option. (in my previous case, no .back was available unfortunately…)

From your reply, actually another idea hit me, I tried loading the “corrupted” project file from C7.5.

Very interestingly, the project file C8 refused to load just loaded OK into C7.5! The content looks intact.
Re-saved the project file from C7.5, and C8 didn’t complain this time.

I’ve got a feeling this issue could be related to 8.0.20, as I don’t remember seeing “Invalid Project file” before.

Have you installed any new plugins recently?

This brings back old, not so great memories… I made it a habit to ctrl-alt-s in order to write new project files all the time - just in case this would happen again. I haven’t encountered it for maybe 8 years, fingers crossed. Sometimes it helps to remove all the available plugins from cubase (rename vst folders temporarily) and then to remove all bypassed plugins from the session in order to make nasty projects load. This has worked for me, but I have not had the dreaded ‘invalid project’ for ages, just projects which wouldn’t load without that error message.

Michael

Thank you Mauri. Since 8.0.20 installed, I’ve installed UR44 driver and SAT phaser.
(Omnisphere 2.1.0 too but it was after my original post, I exclude it from the list of suspects)
I’ll try to uninstall them and see if it makes a difference.

Thanks Michael for your suggestion, I’ve renamed the VST folder, almost all plugins won’t load this way.
Unfortunately it didn’t remove the complaints from C8.0.20. When trying to open the “corrupted” file, immediately C8 claims the project file is invalid. It didn’t even reach the point to check the missing plugs.

ATM I tend to think the issue is really in the .cpr file itself. A long shot guess, it could be a part of the header like checksum is corrupted when saved.
Alternatively, C8.0.20 check might have become stricter before? Considering the fact that C7.5 succeeded to load the same “corrupted” file…

Happened again. This time, the “invalid” file was supposed to be an archive, and I need exactly that file.
(.bak file is an hour old, missing some edits)

A good news is, C7.5 succeeded to load the “invalid”" project, so I didn’t lose the content.
However, re-saved the project from 7.5, this time C8 still complains it’s an invalid project file.

Did some experiment, I deleted all track data (leaving all plugins settings unchanged) and re-saved, and C8 was happy loading the project file. Something doesn’t quite add up.

At this point, it has made me believe that this is a C8 regression. Most likely introduced by 8.0.20 update, as the first date I encountered this was in June.

Successful save can no longer be trusted, if the file is reported corrupted at a later date. I dare to say it is one of the most basic things in any type of apps.
I saw a few other similar reports on the net, so probably not for many but not just me.
And as for me, this is happening a few times a week.

Folks at Steinberg, I would appreciate this gets fixed ASAP. Thanks!

Cubase 8.0.30 has been released.
I tried loading some of those files that were previously reported invalid with 8.0.20, and now they seem to work.
I am able to load those files into 8.0.30. Thank you, folks at Steinberg!

Although 8.0.30 has its own downside / regression, that is, sluggish MIDI note editing (which I noticed almost at the moment when I started using 8.0.30), I’ll be using 8.0.30 for the time being.
https://vimeo.com/139061007