Invisible hairpin in part only

I know there are bugs associated with hairpins and spacing, and I’ve read those threads, but I’m not sure if this falls into the same category. I have the following in the score:
Screen Shot 2021-08-06 at 10.26.33 AM

and this in the part:
Screen Shot 2021-08-06 at 10.26.13 AM

No matter how much I stretch the measure and/or dynamics in the part, I cannot get the hairpin to appear, either in galley or page view.

I’ve seen this thread, but there is no solution listed: Hairpin missing in part, but not score - #2 by dspreadbury

Any help is appreciated. Thanks.

It will be because the minimum space for a hairpin (and the gaps between hairpin and dynamics) is set to a bigger value than the space available. Put fewer bars on the line, either with Breaks or Note Spacing changes.

Knock the minimum length for a hairpin down to 1sp (in Engraving Options > Dynamics > Gradual Dynamics > Advanced).

Then try nudging the p over to the right a fraction in Write mode.


Changing the minimum length did nothing, but moving the “p” in write mode took care of it. Thanks!

If I remember correctly, the “minimum length” hairpin setting doesn’t work as expected. At least I know it didn’t work previously, but I don’t recall if it was fixed in an update.

A 1 space hairpin isn’t a pleasant thing - it looks an accent - but it at least gives you something visible that you can drag.

We know that this issue is quite a vexing one when it comes up. We have done some work in this area (indeed, the fixes to date are included in the iPad version) and you should find it much improved in the next major version of Dorico.