iPad Airdrop to Mac Failed because of Japanese character


Congratulations and thank you so much for making Dorico available to the iPad.

I use an iPad 12.9 2020 with PadOs 14.7.1 and Dorico for iPad
I can’t share a score I created with the paid version of Dorico for iPad
to my MacBook Pro 16 inch 2019

I wanted to send it to my MacBook Pro as I don’t have an alphabet keyboard connected to my iPad
and I didn’t found a way to delete bars on the iPad.

I tried to transfer this Dorico’s file to a USB memory
but my MBP couldn’t open it either.

Best regards,

which version of Dorico are you using on your MacBook Pro? There are certain limitations, if you use the free SE or the Elements version.
Besides this, if your aim is to delete bars from your score: have you tried (in Dorico on iPad) to use the Bars-Popover? The text to put in would be -1 to delete a bar or -10 to delete ten bars, +1 to add a bar, and so on.


Thank you for the Bars-Popover -1 idea.

I use the Pro version of Dorico on MacOs.

I tried with a new project on the iPad and I could share it to my MacBook Pro.

It was because the Title of the project was in Japanese katakana.
When I changed the title in Roman character I could send it to my MacBook Pro :grinning:

There is not supposed to be a problem with non-Alphanumeral file names.
Both macOS and iPadOS use Unicode to deal with file names (not like Windows 9x / NT4).

I suspect that Dorico does things in the same Unicode approach. However, I would like to hear @dspreadbury’s confirmation.

Another, easy way to delete or add one or more bars on both desktop and iPad is to use the System Track, the grey bar above the score, if it’s visible. Select the bars you want to delete or the number of bars to add and it turns orange with a waste bin to delete and a plus to add one or more bars.

Thank you Nickie_Foenshauge
I was trying to use the trash next to the cut copy paste cycle icon :sweat_smile:
You are perfectly right, the trash can on the system track works.

Hello ShikiSuen
I tried those titles on the iPad
and I could send it with Airdrop.

All those titles failed to be sent with Airdrop


I’m still waiting for Daniel’s response to confirm how Dorico handle the encoding of file names read-in and write-out. In these years I airdroped lots of files from my iPhone to my mac with Chinese filenames. The problem could probably be related to how different file systems handle certain Japanese characters like U+30FC, U+3099, U+309A, U+309B, U+309C, etc.

There’s no reason why any particular filename should not work, provided it does not contain any illegal characters; characters that are illegal in filenames are things like : / ? etc. All filenames are interpreted as UTF-8 strings. Dorico doesn’t do anything with the filename itself for AirDrop: it simply hands the path off to the operating system and iOS takes it from there.

1 Like

Thank you for your reply.
For sure the same project with a different title can be sent or not with AirDrop. :face_with_hand_over_mouth: :thinking:
I upload one of them that I transfer from my iPad with Flash memory.ザリー.dorico (485.5 KB)

I’ve looked at this in the debugger and I’m afraid at the moment I’m at a loss to explain what might be going on. Dorico is correctly saving the project and passing the correct thing to the share sheet, but something is happening when that file is transmitted via AirDrop that causes the transfer to fail. I will try to research the problem further to see what else we can discover.

We’ve been looking into this further today and it appears to be an iOS bug. We’ve reported it to Apple and hope that they might fix it in a future version of iOS. If we get any further feedback from Apple, we’ll let you know.


Thank you for your help dspreadbury

I’ll change the title to English for now.

Actually, I have a thread that it’s not solved yet about syncing issue when adding tempo indication to a score including imported sound with dummy video.

Thank you for your reply.

I still think there is something strange.
As I couldn’t share the Dorico’s iPad projects with AirDrop I tried with
Files application or with the sharing button on Dorico for iPad to an USB-C flash memory.
Sometimes I could open it on my MacBook Pro
but most of the time I got an error message.
I attach one of the files I couldn’t send with AirDrop, finally imported with USB memory but I couldn’t open.

ナザリー.dorico (681.2 KB)

CleanShot 2021-08-12 at 11.24.30@2x

I had a similar problem a few years ago - might be more than a few years, but it was well after Unicode had been implemented on Mac. In a school with many Vietnamese students, one student came in with a document which was giving problems - possibly Microsoft Word and/or created on Windows, but I won’t venture into that minefield. I can’t remember the exact symptoms but the solution was to use only English characters in the file name, rather than the Vietnamese characters which had been in the original name. Other documents with Vietnamese characters in the name were fine. Given that we did not have enough time to figure out which particular characters were causing the problem, we just renamed the file and it gave no problems after that.

The reason this file cannot be opened is that it appears to be incomplete, or otherwise corrupted in such a way that the zip compression has been interfered with. I can’t account for why that might be the case, or say whether it might be related to the same issue that prevents AirDrop from working.

On Dorico for iPad, I create a new project with a Japanese (Katakana) title.
and a Japanese (Hiragana) composer
I tried to send it with AirDrop and it failed.
I deleted it.
I create a new project with the same title and Composer and copied it one a USB flash memory,
and I couldn’t open it with Dorico on my MacBook Pro.
(I have no problem if the title is in Roman character)
After trying a second time to transfer the project with USB memory
I could open it :flushed: but still not send it with AirDrop.

I could reproduce this phenomenon.

I also noticed that, as the Dorico for iPad interface is dark,
It’s hard to input Japanese characters, as the letter is white and the selection letters
also is white.

I attached the new project and a screenshot of the character issue.
ゲンキ.dorico (481.4 KB)

ゲンキ same project but imported 2nd time.dorico (481.4 KB)

I could send with AirDrop a project with another app for iPad (Affinity Designer)
with the same title, I couldn’t share with Dorico for iPad (ナザリー) or (ゲンキ) without a problem.
It really seems that is Dorico’s problem :thinking:

We have reported this bug to Apple and there is nothing further we can do until we receive feedback from them. We will update this thread if we get any feedback from them (which would be unusual: Apple do not typically respond to individual bug reports submitted by independent software vendors).

1 Like

Thank you for your reply.
It’s difficult to accept that transferring files errors with AirDrop and USB is an Apple problem, as it only happens when using Dorico for iPad.
I will not send links to other threads of unsolved issues, but how get it fixed?