Is Hyperthreading hurting performance?

My performance meter jumps up considerably

Same happening here nothing helps but turn off Hyper Threading.

I9-9900k 64 ram 1tb evo 970 NvMe Mother Board Gigabyte Designare and RME UFX+ Conected via Thunderbolt on Designare.
Pictures Here
Same project 176khz Sample Rate, buffer size 256, couple (15 at maximum) of plugins.

https://ibb.co/4Zw5hTR

https://ibb.co/QXDLfnR

With all due respect, that’s not true.

The OP noticed something in the performance meter which, as peakae correctly explained, is perfectly normal.

You observed something quite different: that under some circumstances, hyperthreading can slightly impair performance. That is not surprising. This is explained in detail on the Steinberg support page.

FYI, what you’re doing is not a good performance test. You don’t have enough signal paths to fully utilize your cpu. And monitoring every track like that conflicts with asio guard.

I Just showing that with HT enable I get worse results than when disable. Just a fact it’s not a test man, once I’m not trying to discovering any theory behind it or even trying to understand. At this moment, be best result I get is HT off.

I understand. I’m simply pointing out you are seeing exactly what you should expect to see, with respect to hyperthreading, when you use an unrealistic example like the one you are using. Here is a quote from the relevant Steinberg support page:

Enabling SMT/“Hyperthreading” while ASIO Guard is active usually has a positive effect on the overall system performance and is the recommended combination. Only in rare cases - e.g. with projects using many “live” tracks - SMT can still lead to performance issues. Again, please refer to the dedicated ASIO Guard article for details.

https://helpcenter.steinberg.de/hc/en-us/articles/206625630-Hyperthreading-Simultaneous-Multithreading-and-ASIO-Guard

Your picture shows 1ms latency before ASIO guard, which means your buffers are way low at 32 or 64.
Try raising the buffers and leave hyper-threading on.

I tried the same, turned off HT. No difference for me at 44.1kHz, 256 buffer size at a high demanding project (ca. 85% average load, real-time peak went to red at both configurations).
The CPU increased from 41% up to 65%, so I went back and enabled HT again.

Then I’m a rare case: far better results on cpu load with hypertreathing off with 64 or 32 samples buffersettings, 24 live audiotracks and lots of realtime processing using plugins with zero latency only.
A roundtrip latency (including ad/da converters) of more than 5 msec is unusable for me on vocals and livedrums.

But that’s exactly the point, applies to lower latencys only

32 /64 buffer setting is really very low. Can you not simply monitor outside of Cubase and have a higher buffer setting?

Works for me, no problem. The past 20 years. RME digiface soundcard…