Is this a good solution for latency?

I am trying to solve my latency issues in my recording setup.

I have a input latency of 24ms and an output of 47ms. What I did was record the click using a microphone and then looked at how many samples the recording was off where the click should be. It was out by 2475 samples.

So in Device setup in the VST audio section I clicked the “adjust for record latency” check box and entered 2475 samples. Then the click seems to record correctly.

This feels like a very low tech solution to this problem.

Is this ok? or is there a better way to do this?

Hi,

Your specs don’t show your system components (audiocard, processor), but such values would not suit me in anyway : too much delay at the tracking stage at least. I usually work with more or less 6 ms without problem even at the mixing stage and, believe me, the E-Mu driver isn’t the best one out there, latency related. OK, my projects are never big ones : just 5 to 15 tracks with inserts here and there and one or two FX/send tracks), usually, but still…

So, are you sure that you are using the dedicated ASIO driver of your audio card ? If not, the latency will indeed be at such values or more. If you don’t have an ASIO driver, you could try to use the generic ‘ASIO for all’ driver which can be found on the web : it works fine with some audio devices. If you use the DirectX or the Microsoft generic driver, you will never get decent latency values.

Once you have the ASIO driver, The ‘Adjust for record latency’ is one point but it’s not sufficient. To get the latency as low as can be, try adjusting the latency in the device panel of your audio cardas low as can be without crackles or pops appearing at the different stages of your project. Try also setting the ‘Audio priority’ to ‘Boost’. The rest is dependent of your DAW : processor, programs and processes used in the background, devices and drivers used, and so on. Sadly, each DAW is more or less unique. Each of us has to tweak it, to some extent.

If you want to have an idea about the latency of your system, you could do the following :

  1. Create a stereo audio track.

  2. Create a MIDI/VST track (‘Devices/VST instruments’, F11) with any VSTi that can give you a sound with a short attack (BFD2, as an example).

  3. Create a stereo output buss (‘Devices/VST connextion’) named ‘Stereo out 2’, as an example. Set the Device port to ‘Not connected’.

  4. Route the output of your plug-in parameters automation track (in the ‘VST instrument’ folder, the one with mute and solo buttons) to the newly created output buss

  5. Set the input of your audio track to ‘stereo out 2’.

  6. Important : activate both MIDI and audio tracks for recording.

  7. Record few notes : you should have both MIDI and audio events created.

  8. See the delay between them by setting the time ruler to ‘seconds’ and zooming.

As an example, here is what I get with my latency set at 5 ms (6.757 in / 5.488 out) : more or less 9 ms between the two. You could do the same thing with an instrument track instead, the results will be the same.

Hope this will help.

EDIT : maybe you’ll have to click twice on the image link. The first attempt sometimes display an error…
VSTDelay.jpg

Cubic13

Thanks for the detailed reply. I have updated my signature to give more details about my setup.

I am using the right drivers for my Onyx sound card. The buffers are set for to maximum right now as I was getting a lot of click and pops as the project I was working on was using a ton of heavy use VST instruments. Normally I don’t have the buffers set so high so usually latency is not as much of an issue.

I tried your test and it gave very different results than the test I did. Though I think I am was testing a different type of latency than you are testing.

What I am trying to fix in my system is how well cubase tracks recorded audio material while playing back existing tracks. Your test also is testing how long it takes for cubase to generate audio from VST sources on the fly and adds that latency to the to the input latency right?

I have attached a screen shot of the tests I have done. The first track is the click generated by cubase recorded through a mic on the studio speakers. It shows a latency of 2475 samples. I then adjusted the record shift in the VST audio setup by that amount and recorded the click again. That is the second track “adjusted click” as you can see it lines right up on 0 where it should be.

Next two tracks are the test you recommended. As you can see the latency jumped to 6250 samples in this test. Is the because the input and output latencies are both in play??

Also when I tried to adjust the record shift to correct the second test it no matter what value I put in the test yielded the same result. That is puzzling to me.
latency test.jpg

Hello,

I recommend to use different sound card. This one has not good driver. Or try tu use universal driver ASIO4ALL, maybye, it will give you better results, than original driver.

Best

Just an update from me. I have updated to the latest cubase and drivers for my audio card.

So the old drivers for the onyx400f would go up to 2048 buffer size (I had it set to this to stop the clicking and popping) and the new ones only go to 1024 samples.

However the new ones are optimized for windows 7 and now my project is happily running at 512 samples in the buffer. (seems to still run well with it set even lower) Input latency is now down to 7.26ms. I have the record shift set to 657 samples which seems to line things right up when I am recording audio.

However this is really the same solution that I had in my first post.
Is this the way to go?

As far as I know there’s nothing wrong with it.

Cheers, Matze!

Hi, whitla

I don’t think that recording Cubase click with a mic on studio speakers is relevent to determine your overall system latency. If you put the mic at 30 cm distence it will give you around 1 ms of added latency and if you put it at 3 m it will give you nearly 10 ms more !

About the fixed latency value that you get on my procedure : it is normal as there is no true audio recording. The audio you get doesn’t go through the ‘normal’ audio recording process, but is generated via ASIO routing, thus subject to the inherent latency of your DAW, so the correction of the ‘Record shift’ is not applicable.

The 6250 samples latency were much too big, no matter if input and/or output latency is in play. Glad to see that you got a better driver since. Now, as it seems that your problem is concerning audio takes, the procedure of my first post is not relevent : as for the ‘Record shift’ parameter, all depends of what you are recording : a live set ? Line in from external instruments ? There is also the phasing problem that can arise with several mics, the distance between mics and instruments (or voices) recorded, and so on… I think that, more than chasing the samples one by one to eradicate anything related to latency, the whole thing needs an empirical approach, with a lot of listening, but to each is own…

The procedure that I was talking about is not really a test : it is only a result of what I get at a fixed latency value in the Device panel, this for the use of VSTis : it shows that I get a value which is not an exact sum of both input and output latencies, otherwise I would have get a little more than 12 ms. To be honest, I don’t have the knowledge to explain the result. One thing is sure : I always get a result directly proportional to the latency set in the device panel (about 1.8 tme of it). Would this be the same with another driver ? I don’t know but, again, audio takes needs to be taken in a whole different approach.

Cheers,

Thanks for the response. That stuff about the speed of sound has got me thinking.

Yes my concern is audio takes. Usually one person is doing the overdubs playing or singing to existing tracks.

What you say about listening also makes a ton of sense. Being aware of what your latency seems the be the most important information you need. Then you can act accordingly.
I’ll try and keep my ears open.

You have done it correctly. It says all you need to know in the Devices setup/VST audio section help file.
Don’t know if it’s low tech but it is simple and that’s a bonus in Cubase. Usually it’s a three button choice and a hail mary. :mrgreen:

OK I did some new tests this morning and got some really interesting results. This time instead of using a mic I just patched a direct out (headphones) from the sound card and went right back into one of the inputs. Then I tested where the click lined up at 64, 192, 512 and 1024 samples. This time with the speed of sound travelling through the air out of the equation cubase did a much better job. Every time it lined it up within 1ms with the exception of 1024 which was a hair over. You can see the results in the attached pic.

I am going to leave it at 512 and just adjust a bit back in time to get things damn near close to as they were performed.

Thanks for everyone’s input I learned a ton about this stuff going through the process. Knowing what I do about the speed of sound you can bet I’ll be wearing cans when I track!
Direct latency test.jpg