Issue Assigning Faders to CCs

I’m trying to set up a Behringer BFC200 controller with Cubase so I can use the faders for modulation, expression, and volume. I’ve set the device up as a generic remote controller, added and learned the faders, and assigned them to CC s 11, 1, and 7 for expression, modulation, and volume, respectively. However, none of my tracks are responding to the faders, and when I hit record, none of the expression, modulation, or volume data gets recorded. How can I get these faders and cc’s assigned correctly so I can begin using them?

Make sure you have “write automation” enabled. The “RW” keys enable writing and reading of the data.

Even with RW enabled, it’s still not responding :confused:

I prefer to write CC Data to the Midi Part rather than Automation Lanes.

Also, I set my controller to send the correct MIDI CC directly to the track - not as a Generic Remote.
I assume you can do this on the BCF2000.
You might try this more direct method.

I do use the same controller for some other “Generic Remote” Functions.
I keep these from being recorded (if used while recording) by setting them all to MIDI Channel 16 and using the Input filter (In Preferences) to remove that channel.
The Filter does not prevent Generic Remote commands.


Hi Hugh,

Yes, I definitely want to record to the MIDI part rather than to automation lanes. Can you tell me how you set up the controller to record directly onto the track?

Also, is there a way to have these faders permanently set to expression, modulation, and volume for Cubase as a whole? It would be very time-consuming to have to re-assign them every time I add a new track.

Thank you for your help!

I don’t have a BCF2000 but I was assuming that you could program the Faders to output these various CCs.

Then simply make sure that the BCF MIDI input to Cubase is included in the “All MIDI Inputs” selection in Device Setup.

You Don’t need to use R or W for automation. Just record on the track.
In case you have some non-default settings, you can set the default destination for CC data in the “Automation Destination Setup” Dialog (that’s the wrong name - can’t remember what it’s called - it’s in the Menus somewhere)
But the default is CCs to Part.

Select “All MIDI Inputs” as the source for your Track (This so that the track will receive your keyboard AND the BCF’s CCs)and you’re good to go.

Does that work?


Quick search gave me this.,_button_or_fader_on_the_BCF2000%3F

You can probably find better but it gives you the idea . . .


Yep, that’s what I’d like to do but I’m having trouble figuring out how to program the faders to the correct CCs and actually get the computer to respond accordingly - any tips on how to do that?