Issue - bugs in midi assignments + global part

@Spork I was able to reproduce this bug in a clean project. Actually, it looks like I found 3 bugs:
Bug 1:
1 - Create a part with a midi controller.
2 - Unlink the midi controller (eg to )
3 - Play the original midi controller → controller is still linked!
Bug 2:
1 - continue from the previous steps
2 - create a global part
3 - add as many layers as you have controllers and assign them to the layers.
4 - assign “Virtual midi: VM Out 1” to the outputs of the global layers, and “Virtual midi: VM in 1” to the input of the “song parts”
5 - All controllers work as configured.
6 - restart VST live and load the project. → nothing works anymore
7 - Go to the global part and change inputs to and back to the original controllers → no effect
8 - Try to add a new layer in the global part → CRASH
Bug? 3
Anytime you reopen the previous project, I get this message while all my midi devices are connected:

image (1.2 MB)

Trying to understand your problems, thanks for the project!

What do you mean by that? Sorry but there are MIDI controllers everywhere and I don’t know what you mean.

I assume you are talking about “Actions and Shortcuts”, right? Then “eg to” means Data2 to? Tried that, it works (testing upcoming version).

Sorry, you lost me. What controllers, your physical ones?
4) I also don’t understand. Pls. be aware that VM1 and 2 are really cables, so what you send to VM1 out can be received at VM1 in.

Pls. try to be specific, what “input” are you talking about? Layers, tracks, actions…?
If you mean Layers: tried that. It’s pretty useless though…also you may create MIDI loops that way. What do you try to acheive?

I can see loads of actions when loading the project, all seem to work well. But obviously need to understand more of what you are actually doing

What inputs? Layers? Layers are routed to VM1 out (“Midi Out Port”), what do you try to acheive?
I can change those and add Layers in the global Part after loading your project. So obviously must be missing something, pls. enlighten me :slight_smile:

I did try this though:

  • one Global Part with one Layer. It receives from a keyboard. Out to “Midi Out Port” which is VM1.
  • one Song with one Part receiving from “Midi In Port” which again is VM1.

Selecting (nc) for a Layer Input doesn’t appear to work correctly, will be fixed with the next version so maybe try again then. But still, chaining Layer MIDI like this doesn’t serve much of a purpose?

Regarding Bug1: I am not able to recreate it anymore. So please ignore for now.
Bug2: Sorry, I fell into the same trap as many others do: leave out the essential information.
My goal is to midi merge inputs within VST live. This is the setup I try:

The picture is showing an example where I use 3 midi controllers to control one layer. The separate midi inputs are “merged” in the global part into this VM Out 1. The different layers in the parts are then used “VM In 1” as an input to control the VST’s.

When I initially set this up, it works marvelously well. When I save the project, close VST live, and reopen then this happens:

  1. Open VST live project
  2. Playing the NI Kontakt S88 midi controller does not result in midi activity as you can see (0:00~0:04).
  3. If I add an extra layer into the global part, VST live crashes (0:06~0:08).

You already mentioned to me twice that “VM1 and 2 are really cables”. I hope that the way I use these “cables” is the proper way. I really want to avoid having another software running in the background to midi merge USB devices or to extend my 19-inch rack with a midi interface just to midi merge devices.

I see now, you are “just” trying to create a merged input. Just so that you know, we will add multiple selection to ports in Connections (incl. MIDI Inputs) soon.

Just tried it with the upcoming version, works like a charm. Using Global Part to create multiple Layers, each with its own unique MIDI Input, all out to VM 1 out, and have any Layer in any Song receive from VM 1 in, no problems. Save, exit, load, all there. Also add and remove Layers to/from Global or any other Part causes no problems. So pls try again with the next version. We will also add a loop (shortcut) check for VM ports soon.

1 Like

Tested in the new release and works like it should! Thanks for saving my spring “tour”!