Issue: cannot import simple MIDI file into song

I created a backing track in Cubase using midi and virtual instruments. I created audio mixdowns (WAV format) of the instruments and imported into VST Live. This works.
I now want to add some MIDI control to switch patches on my guitar pedal while playing with the backing track. I created a simple MIDI track in Cubase with six program change commands in it. This works well in Cubase. I export the MIDI file and import into VST Live.
Only about one third of the MIDI file ends up in VST Live no matter what I do.
I have validated the MIDI file, by successfully re-importing to an empty Cubase project. Cubase version 12.0.51, VST Live version 1.1.20.

… can you give us the files? Then we will analyse the file and see what’s going wrong while importing them.

Thank you,

Hi Michael,

Yes, of course! The MIDI file is attached below. It has Program Change instructions at bar 1, 19, 28, 35, 44, and 54 - just switching between patch 1 and 2 on my Boss Me-80. The import (File-Import MIDI) into a 58 bar song results in a MIDI track that is truncated in bar 26. If you need the VST Live project file then please let me know how to upload it … this dialog does not let me upload that file extension.
Happy hunting!

ME80 Automation Data.mid (141 Bytes)

hi daveturner, thanks for the file. Loaded it and it extends to 54 bars (at tempo 120, that is). Is this not the correct length? Also checked that it sends Program Changes.
It could be that we fixed it already (using upcoming fixes), just want to make sure that the issue is understood correctly, thanks.

Hi Michael,
That is good news … yes, bar 54 would be about right, that is the point of the last program change. I’ll await the next update then!


Hi Michael, Following your last message, I tried importing that MIDI file to a new, empty song. It worked, which made me think that there is something about the song that is causing the problem. In my efforts to find a bypass I did some experimentation, and now think it could be the signature track I have in my song that is the cause. The following happens on my system.

Case 1
Create a new project. Set the tempo to 58 BPM.
Add a signature track. One entry at 1.1.1 of 4/4 is created by default.
Import the MIDI file. It works.

Case 2
Create a new project. Set the tempo to 58 BPM.
Add a signature track. One entry at 1.1.1 of 4/4 is created by default.
Add a signature change at bar 53.1.1 to 2/4 time.
Add a signature change at bar 54.1.1 to 4/4 time.
Import the MIDI file, and it is truncated somewhere in bar 26.

An additional related problem. When the MIDI file is imported, it appears as the correct length, the end of the track is where the final Program Change should be. The last instruction itself appears to be missing though. Running the MIDI Monitor shows five changes being issued instead of six.

Can you take another look please? Many thanks,


… yes, we can reproduce the problems. Please hold the line.

… fixed. Next update.


That was quick! Thanks Michael … I’ll look forward to the update.