Issue: Cubase 11.0.20 virtual keyboard behaviour

Problem: The floating window for the virtual keyboard is not behaving as expected when you also browse and preview instrument presets.
The virtual keyboard window is “fighting for control” with the built-in keyboard of the preset browser.

Steps to reproduce:

  • open the virtual keyboard
  • in the right panel, navigate to Media - VST Instruments
  • select an instrument with presets that can be previewed, e.g. Retrologue or Padshop
  • select a library
  • select a preset
  • make sure computer keyboard input is active in the preset browser

You should now be able to play the preset. It correctly uses the right panel browser keyboard.


  • now double-click a preset to load it into the project
  • play notes on the computer keys and observe the still open virtual keyboard floating window. you can play notes, but they no longer are shown as key-presses. (BUG)

You’d have to re-open the virtual keyboard to see the played notes again.


When you have the floating virtual keyboard window opened and preview a preset at the same time:

  • disable the computer input with the button in the preset browser

Expected behaviour: The floating window for the virtual keyboard is still open, I expect Cubase to return the input from the browser back to that window. So I could play the selected and armed instrument track again.

Issue: disabling the browser-based keyboard completely disables the virtual input, although the window is still opened. I have to close and reopen the virtual keyboard to gain control correctly again.


Also while having the virtual keyboard window opened and previewing presets:

  • close the floating virtual keyboard while the browser preview is enabled.

You are no longer able to play notes in the preview, although the computer input button in the browser is enabled.

In short: these two things fight for control, need to be synchronized and while I have the virtual keyboard window opened, I always want it to have control.

And if I close it while previewing presets, the browser keyboard input should still work, if enabled.


Info: macOS 11.2.3 Big Sur

Intel-based iMac 2017, 27" model

A post was split to a new topic: Virtual keyboard filtered my key commands, although the virtual keyboard isn’t active