[ISSUE] Cursor location not updated inside a macro

Nuendo version 6.0.7

OS : Windows 7 pro runing on a dual core Intel Processor.

Problem :
When running a macro from a control surface, the cursor location is not updated.

Consequences :
Macros relying on cursor positions will not work from a control surface, or will work from time to time.

How to reproduce :

  • Create an audio track and place an audio clip on it
  • Select this track
  • Place left and right locators somewhere on this clip
  • place the cursor to the right of the right locator

Now create this macro and run it from the Edit - macro menu :

  • Transport - to left locator
  • Transport - Nudge +1 Frame
  • Edit - Split Loop
  • Edit - Select under cursor

You should get the clip splitted at locators positions, and this new clip selected.

Now execute this macro from a control surface :

You will still get the clip splitted between the locators, but this time the selected clip is the one at right of the locators instead of the clip between the locators.

This show that the cursor location is not updated internally during macro execution from a control surface, the “select under cursor” command see the cursor position before the macro start. To say it differently if cursor position is changed by the macro code, those changes are not taken into account for the “select under cursor” commands.

It did your repro.
Everything is working correctly.
I cannot confirm the issue.

Thanks John for your report. Two small things :

Did you put the cursor at right (or left will give the same problem) of the locators before to run the macro ?
This sentence is critical “- place the cursor to the right of the right locator”.

If you have the cursor between the locators before to run the macro, it will always work regardless if it is run from the macro menu (or from a shortcut assignation) or from a control surface.

What kind of control surface are you using ? Is it using Eucon or Nuage protocols ? Or the midi remote protocol ?

I’m using MIDI remote protocol (JLCoopper MCS-3800 in native mode). I’m on Win7 32 bits.

I tried with Nuendo 5.5 and got the same problem.

It works the same regardless of cursor position.
Make sure the track that has the clip you are editing, is selected.
I am using an Avid Artist MC Control (Eucon).

Yes the track is selected.

I feel that this problem does not target the Eucon engine.

I tried this on the Nuage and the Euphonix MC Pro running Eucon 2.7.0. Worked perfectly on the Nuage but on the MC it ran with the same problem you have where the clip to the right of the locators is selected. Worked this way whether the cursor was to the right or left of the locators. john.

Thanks Dog and Pony, this show that this problem is targeting two different remote subsystems, the Eucon and the Midi remote ones.

As there is eventually a low probability that this will be corrected soon, i will change my mind and i will use keystroke emulation in combination with Midi interception to get the job done.

Using keystroke emulation i will fully bypass the faulty macro engine.

Efficiently interfacing a control surface is a difficult job as soon as you don’t have a high end one !

And if you keep it with default functions then there are good chances that you’ll have something that will not be really more useful than a mouse. Eventually you will end up using back the mouse for most jobs instead of the control surface… And you’ll have lost a couple k$.

Buy Nuage or Nothing :smiley:

Thanks for your help.

Buy Nuage or Nothing

Keep in mind, we’re running Eucon 2.7 in that room, John Gar posted that your macro worked correctly on his Eucon system and I’m pretty sure I read that he’s on 3.0 so the macro problem is likely just a matter of an upgrade. John.

Yes, I am on Eucon 3.1

Thanks for the precision. I will try to install the latest version of Eucon and see if this does have an effect on the macro engine when using midi remote.

Eucon is not installed on my setup actually. I doubt that it will have an effect but who knows.

In the meantime i did start to use keystroke emulation and that is solving this problem. Nevertheless most users will not be able to do that because of the needed programming even if there are some third party utilities available that will help a lot here.