[ISSUE] drop midi files to inst track creates new midi track

[ISSUE] dropping midi files on instrument track creates new midi track
REPRO:
Create instrument track
Drag and drop a midi file from file browser on Instrument track in project window

Result:
A new midi track is created with the midi file name.

Expected result:
Midi file is dropped on the Instrument track.

This happens regardless of the correct preference settings.
This creates extra work having to move the midi part from the new midi track, then having to delete the newly created and unwanted midi track.

Check your MIDI import prefs (import destination -> MIDI tracks, import dropped file as single part, auto-dissolve format 0). I can drag ‘n’ drop a MIDI file from the browser directly to an instrument track without problems.

1 Like

Yes Thanks.
Like I said, the preferences are correct. It has no affect on what happens, a new midi track is always created.

Can you post a pic of your preferences pane along with a short video of the issue (LICECap is good for this). I can not reproduce when dragging from browser to instrument track.

The gif shows dragging and dropping from addictive drums browser, then from windows browser.

https://www.amazon.com/clouddrive/share/t6UT49KNiByGoHbr5pWx5EOYNim9pba575MkywtpiZ?v=grid&ref_=cd_ph_share_link_copy

Here are my settings which seem to work fine.

http://snag.gy/eZOyB.jpg

GIF attachment shows it working from Addictive Drums.
dragndrop.gif

Thanks again, but it does not fix the issue.
Maybe I’ll trash my preferences, I don’t like doing that.

Trashing preferences did not fix it either.

Edit:
I tested this in Cubase 8.5 and it works correctly.

I opened Cubase 8.5 and added an instrument track with Addictive Drums.
I drag and drop from AD’s gui on to the instrument track and the midi file drops on the instrument track as it should.
I saved this project and then opened this project in Nuendo 7.
I can now drag and drop on to this instrument track in the Nuendo project, however, if I create a new instrument track in this Nuendo project, when I drag and drop on to this new track, it creates a new midi track. If I drop on to the original AD track, it does not create a new midi track. Even though the preference settings are identical to Cubase 8.5.
I should also note, that I have started Nuendo in safe mode, and it does not solve the problem.

1 Like

I have the same problem in Nuendo 11.

Does anyone know how to solve this?

If someone will encounter this in the future: the solution is to switch the track time base from linear mode into musical.

3 Likes

In Cubase the settings posted by twelvetwelve work correctly. No new Midi track is created when dragging midi from a VSTi to the arrange Instrument track.

In Nuendo the same Preference settings need to be set that twelvetwelve posted but you also need to follow the step ukompaniets posted and change the Time Base setting on the track from Linear Mode to Musical Mode (Nuendo only). If you want Musical to be the default in Nuendo you can also change the default Time Base setting in Nuendo’s Preferences > Editing > Time Linear to Musical. Once you do this you’ll have the same behavior as Cubase mentioned ^^above^^