Issue. Groove Agent "click" noise when playing sample

Today, when working on a CPU demanding project, I noticed that hi-hats on Groove Agent were clipping. No processing on the track and nothing went to red inside Groove Agent, on the channel or stereo out.

No problem when adding other VST instruments, but when I add another Groove Agent, the samples also clip.

There is a clipping noise just before the sample when looking at the bounced waveform.

When I play the Groove Agent hi-hat on a midi keyboard then the first hit comes in with the clipped sound and the next hits are ok. Then I paus for some seconds and again the first hit clips.

The only solution I found was to bounce the track and cut out the clipping noise.

Buffer size 2048.
Cubase Pro 13.0.20
Audient ASIO driver
Win 10
i7-9700 CPU

maybe a couple of things to check into:

  • What’s total Windows RAM consumption looking like?

  • Is it happening on different kits, too?
    • If not, maybe check the hi-hat samples of that kit just to ensure, that one of the samples isn’t faulty. Or put a different hi-hat sample set on that kit if possible?

Thanks Nico5 for the response and suggestions.

My CPU usage shows 42% and MEMORY shows 44% when playing back the project, so it seems my PC is not maxed out.

I tried the RAM balance slider but it didn´t help.

I tried changing the buffer size and it also didn´t help.

However I found something weird.
The samples from Groove Agent “Vintage kit” and “Studio kit” have this clipping artefact but the samples from Groove Agent “The Kit” and “Metro Heights kit” does not have this problem.

I now found that this happens also when I create a new project with just the Groove Agent instrument. No plugins, nothing else.

This “clipping” does not sound like it´s distorting, just a “click” before the sound. It´s like the click you hear, when you cut the audio and don´t use crossfades.

I recorded a video of this bug.

From the video, you can hear the “click” when hi-hat is played at the slower pace but the click is gone when played faster.

Can you tell the difference between physical memory and virtual memory? Because virtual memory relies on swapping memory contents to disk (a rather slow operation). And at least in theory that could cause grief for something as timing sensitive as real time audio.

Not sure, if you can see the raw samples in the problematic kits - if yes, might be interesting to see, if one of the samples is flawed.

In any case, another interesting experiment might be to replace that hi-hat with a perfectly working one from another kit and save the resulting kit as a custom kit.

I haven’t played around with doing such a thing myself, but it’s something I might attempt in a case like this.

But there’s other things you mentioned which seem weird: For example that you haven’t seen visual meter evidence of clipping inside Groove Agent, but just outside.

Other avenues of investigation might be a bit more onerous: e.g. comparing hi-hats between kits that work fine and where they don’t. There’s potentially lots of different things going on including multi-sampling round robins, velocity sensitive multi-samples, and possible special logic for cutting off a current sample.

There’s also the possibility of some Groove Agent internal fx processing (e.g. compression), which could add problems or mask them.

Thanks Nico5. I found out what was causing the clicks.
It was the “tube” mode under Groove Agent internal mixer.
Most Kit presets under Vintage Kit have “tube” switched on and when I switched it off the click went away.

I tested also on mac and it has the same problem. I wonder if anyone else can reproduce this bug?

  • Open Groove Agent 5 full version
  • Open Vintage Kit “Laid Back Jam”.
  • Play C4 “hi-hat” or any other sample.
  • Notes played at slow pace have “click” at the start.
  • Notes played faster do not have this “click”.

Here is a screenshot with Groove Agent and bounced out audio showing the click on waveform.

1 Like

wow - so it was a Groove Agent internal fx setting that made the difference!

lol - of course it had to be the very last one of my suggested avenues of investigation, rather than the first one. :slight_smile:

It being the tube fx is quite counter-intuitive, because in real life, tubes tend to compress the signal, rather than introduce spikes. But in software, all kinds of weirdness can happen, some of it negative side effects of positive intentions.

Like for example switching an audio fx on/off, to save CPU processing when there’s no signal for a certain length of time. And as you observed, the click sounded a bit like things used to sound like when an audio track was starting loud enough without any fade-in. (I think Cubase automatically (cross-)fades audio tracks for quite a few years/versions already, so this isn’t a problem anymore.)

So one might speculate that this click might be a little logic flaw in the Groove Agent tube module that become audible in some circumstances?

1 Like