Issue loading DMG plugins on new computer

I recently got a new computer running OS X 12.4 on an M1 chip.
All my other plugins have loaded successfully but I’m unable to find my dmg plugins (which work fine in protools).
I’ve tried reinstalling them, and have tried forcing wavelab to rescan the plugin folder. Is there anything else I can do?

Edit- running wavelab 11

I had a similar issue on my M1 when downloading the individual plugins from the DMG website. I had to use the DMG Mac Combined Installer app they have on their site for the M1 versions to be installed and for WaveLab to load them.

When I asked DMG about this recently, they said this:

Yes, apologies for the confusion. We were keeping the individual installers Intel only until we could bundle M1 native AAX versions into them, which I think we can finally now do, so will update them soon.

1 Like

That did it, thanks a mil justin!

For anyone else having a similar issue, you need to download the ARM Mac Combined Installer ( the standard Mac Combined Installer didnt help). I also downloaded the Mac License Management Utility, though idk if thats absolutely necessary.

And then you need to rescan plugins again.

Not totally a fan of DMG forcing me to install all their plugins. Hopefully I wont start getting demo expiration popups. Though its probably easy enough to find the plugins within the vst3 folder and trash them.

Anyways really appreciate the quick fix justin, youre a saint

Right. I only own 3 DMG plugins and typically just update from the individual installers. There was (and still isn’t) any indication on their site that the individual installers aren’t the M1 versions.

And then a WaveLab quirk I’ve been noticing, when a plugin goes from non M1 to M1 native, a plugin scan seems to be the only way to get it to appear in the M1 version of WaveLab.

FWIW, like the FabFilter install, if you’re careful you can “Customize” the install during the install process via their DMG Mac Combined Installer app and deselect the plugins you don’t want to install.

It’s kind of hidden, but possible.