Issue with Cubase 6 and Mackie Control

Cubase 6.5
Windows 7 64 bit
Mackie Control connected to PC via USB
Mackie Extender connected to main Control unit via midi port 4

When starting everything up for the first time (boot up PC, turn on Mackie units, then launch Cubase), the Extender is not recognized. The workaround is to go to Devices, assign the Extender to the wrong port, and then back again 4 times (presumably this resets the ports and has to be done 4 times because it’s plugged into port 4). Hitting the reset button does not accomplish the same thing.

Prior to upgrading from Cubase 5 to 6 and/or XP to Win7, this was never an issue, and all my physical connections are exactly the same as before when the Extender was recognized right away upon launching Cubase. An hour on the phone with Mackie confirmed that as far as they can tell, every connection and setting in my system is correct.

Has anyone else had this problem, and is there any solution other than the extremely tedious workaround outlined above?

I have had lots if trobles with recognation and settings of the Mackie Controls in my Mac. Sometomes can’t Cubase recognize it, sometimes Logic, sometimes whole system it self. I think, this is Mackie issue.

I switched to the Euphonix - no problem.

Mackie Pro or the original Mackie? Based on “Port 4” I would say pro. I have the original Mackie (which doesn’t have usb) and it works flawlessly. If you have a midi interface you could try connecting the extender via that instead of the main MCU.


I get something similiar every time I start up. the main mcu pro works fine (over usb) but the extender does not show the text in the display. my faders and lights are working and correct though.

For me I need to wait a minute or two, then power off and on the extender, then go to devices and click the reset button on the extender page.

totally a pain, but it does work, then it works for the rest of the day.

It would be great if I could fix that. I’ve been meaning to try a different midi device, but I haven’t gotten around to it.