Issue with Cubase's MIDI and Composer Tools Pro (Solved)

Hi!

I have an issue with the Lemur based Composer Tools Pro (CTPro from now on) and Cubase 10.0.60. I use CTPro to control things like expression maps for my tracks (I use both instrument and MIDI tracks). The problem is that when I change from a MIDI track to an instrument track and then try to switch back to a MIDI track, Cubase doesn’t seem to correctly fire out the MIDI messages CTPro needs to switch to that MIDI track’s preset. Instead, CTPro is stuck on the instrument tracks’ preset. I contacted the developer and according to him “It seems that Cubase has an issue telling the Generic Remote when it goes from MIDI track to Instrument Track, but only on the first selection”.

Has anyone else experienced this or a similar problem? Couldn’t find anything related on the forums (or I missed it) and as usual, the support is taking its sweet time…

OS: Windows 10 Pro 1909
Cubase Version: 10.0.60 Pro

Hi,

This is in area,where I’m hunting for some bugs (there is something, I know it, but I can’t still catch it). Could you make a video for me, please? I’m not 100% I do understand your use case, your workflow and the MIDI data flow. Thank you.

Hi Martin!

As requested, I’ve made a video for you demonstrating the problem. Apologies for the shaky phone came footage!
I’ve also attached two links which demonstrate the MIDI recall setup for Composer Tools Pro.

If you have any further questions I’m happy to answer…this one is a major pain in the butt and I’d love to see it fixed.

https://youtu.be/FXEZUukW9So

https://youtu.be/0vcTaj86Tck

https://youtu.be/mqzHQOMX1eQ

Hi,

Thank you for the videos. I think I understand now, how does it work. But…

I didn’t see, how should be the plug-in triggered, if you just select the Instrument track from Cubase. I do understand the Generic Remote settings. But the Input of the Generic Remote is the Daemon Input 0. But Daemon sends the signal from the hardware device, not from Cubase. And as far as I understand, there is no way, how to force Daemon to send the message to Cubase, once you switch the track in Cubase (if there would be the way, you wouldn’t need the Generic Remote, you could inform the plug-in directly).

So my question is, how the plug-in knows, the track, where the plug-in is living to, has been selected? Is this implemented in the plug-in itself?

And I have to say, I don’t really understand the sense of the Generic Remote. Where does the Daemon Input 0 MIDI Port come from?

Sorry Martin, I’m having a bit of trouble understanding your question, but I’ll try my best!

All communication between Lemur, Composer Tools Pro and Cubase is done via MIDI. The Daemon Input 0 MIDI port comes from Lemur on my tablet.
I’m just a composer so I’m not too technically proficient, sorry. If my ramblings aren’t helpful perhaps you could try directly contacting the developer at MidiKinetics (if someone from Steinberg hasn’t already) or just visiting their site, since there is pretty comprehensive technical section in there. I’m sure as a tech savvy fellow you would get a lot more out of it than I ever could!

Huh…There was a minor bug fix introduced this month and it seems to have fixed my problem. Lucky! I consider this case closed for now. Thanks anyway, Martin!

Hi,

Good to know, thank you.