Issue with Editing Spectrogram then Waveform


I am noticing that randomly there is a possible bug with Spectogram in the current version of WL.

Specifically: edit a wav file in Spectrogram (single channel selected) … then switch to Waveform and try and select a section to edit (eg a click). The Waveform cursor displays the Spectrogram edit tool and will not select anything in the waveform. Go back to Spectrogram and it has made a selection by itself … you can see this and it was not there when switching to Waveform editor.

I have attached screenshots. Spectrogram 1 clearly shows there is nothing selected. Waveform shows what I want to select but cannot. Spectrogram 2 shows that it has self selected a section (preventing a selection in Waveform).

The fix is to close the file and re-open it.

This does not happen often and I cannot reproduce the issue at all.

As I have said before, I personally like to edit stereo wav in WL over RX Advanced (which I own) or SpectraLayers (which I also own) and I use it constantly.

It’s more annoying than a bit issue.

Thanks and all the best

I tried to play a bit with the data you gave, but can’t reproduce a problem.
If you ever find a reproducible step-by-step procedure, come back to me. Thanks.

Thank you … it is completely random and, as I said, I have been unable to reproduce it. But next time it happens I will think very carefully about why and let you know…

Thank you as always

1 Like


I think I may have tracked something down … although not 100% sure.

It may be related to my use of keyboard shortcuts to switch between Spectrogram and Waveform views (Spectrum and Correction tabs).

I have Q set for Spectrogram and W set for wav view.

I have just noticed that using Q always reliably changes the focus to the Spectrum tab to match/follow the Spectrogram view. On the other hand, W does not seem to change the tab focus to Correction … it just changes the display.

So what might be happening is that, after editing in the Spectrum, then switching to ‘Correction’ with the keyboard shortcut W, the Spectrum tab ‘thinks’ it’s still focused and draws a selection while hidden (making it appear like something is preventing the cursor from selecting a section of the wav display … because it it still ‘open’). This makes sense since the Correction tab is not focused.

I have assigned W to Show Waveform and now I am thinking it should be set to Activate Correction Tab … using the pre-assigned shortcut E then E may be the answer. This of course also changes the display to waveform.

Why W was working almost all of the time but not always is a mystery but one that maybe doesn’t need to be solved at this point.

In summary, I am thinking this is ‘operator error’ by not using the correct keyboard shortcut item from Spectrum tab to Correction tab. That is, tab focus does not necessarily follow ‘view’ and this is not a WL bug as such.

I hope that in some way this might be helpful in some context.

Thanks again