Issue with exporting midi and VSTi to audio tracks

I am using Window 10 w/Cubase Elements 11 and the MODX8. I seem to be having much difficulty exporting midi tracks to audio tracks and/or Groove Agent SE 5 to audio tracks. The more I am looking at my output config the more I think I have it set up wrong. I do understand how to export to audio tracks, but there seems to be some issue with my setup because nothing shows up like in the tutorials, which is why I think that my output config is not right. I can’t seem to find any tutorials that clarify this issue though. Can someone please help!!!

Yes, we guess everything what you configured and present a solution… we are magicians…

Well, aren’t you? just kidding🤣
My bad, I was pretty tired last night when I posted this after working at this most of the evening and then finally figuring out that my configuration is probably to blame. I do apologize! My configuration uses the MODX8 as the usb interface between the sound engine and cubase elements 11. When I downloaded the Steinberg driver and started to set up Cubase the only option that I could find was Main left and right as well as USB outputs back to the MODX8, but nothing that seems to point to the correct output when I try to export. So perhaps it would be easier if someone could walk me through setting my configuration with what I’ve explained from above. In other words wipe my slate clean and set it up all over again. Only this time I can set it up correctly via someone’s expert guidance :smiley: matter of fact is there a way to post using screenshots or jpegs? Then I could take pics of my setup and someone can tell me what’s wrong or how to set it up properly. Of course, if that is not possible then could someone just tell me what they need to know about my setup and I will explain it the best I can.

I use Windows 10 Pro. Currently the modx8 is my USB interface. I have Cubase elements 11. In Studio Audio Connections, inputs it shows USB Main left and right the audio device is Yamaha Steinberg USB asio. And there are no other options when I do the drop down. In output it shows Main left and right, audio device, Yamaha Steinberg USB asio, and there is no other options.
In one of the tutorials I noticed that in the studio setup at the bottom left second to the bottom it shows VST System, but the only thing that I have is VST System Link, I don’t seem to have that option perhaps that is the difference between a Mac and a PC. So maybe I’m missing a driver, cause the only drivers that I see in the audio system drop down is
Generic low-latency asio driver,
Model mixer asio, which is my Tascam Model 24 driver, and the Yamaha Steinberg USB asio driver.
Let me know if I’ve missed something.
I really do appreciate your time!

Maybe this will help:

When you can, do offline renders, as those don’t depend upon your audio interface at all. They happen as fast as your CPU can do it. Even if you happen to hear clicks and pops or whatever when playing it back, rest assured those are NOT in the actual audio file if you’ve rendered it internally from VSTi instrument tracks.

Obviously live mixes can be a different animal, and you’ll want good device behavior/performance from the inputs in the least.

I’m on Cubase Pro and there are options for ‘rendering’, LE seems a little different but here are some things I could find that might be of interest.

To do a kind of offline instant rendering of instrument tracks:
Freezing Instruments (steinberg.help)

If you have your performance data in MIDI tracks rather than on instrument tracks, sometimes it might be worth it to move the parts to instrument tracks instead. Of course that can all depend upon the type and size of the project.

In Pro we can instant render MIDI tracks connected to a qualifying plugin to audio as well but I’m not sure about LE. It seems to me in browsing the docs briefly that you’d simply solo the track(s) and instrument(s) you want to render to audio, set the project locators accordingly, and do: Mixing Down to Audio Files (steinberg.help), of which you can import back into the project as a new audio track. If I’m interpreting the docs correctly, it’d be done internally at the full speed possible from your system (unless you have external instruments or effects that need to come ‘live in real time’ from your audio interface included in the mix-down).

Why so many words with so less information? It’s very hard to read and understand what you are writing.

What does this mean?
It could be that your main problem is, that Elements doesn’t support external instruments. I couldn’t find a notice about it.

He is using an external instrument, I guess… so it depends on the interface!

That’s not what this says!

Thank you Brian for your much needed input! The last part of your post I am very familiar with but it does say in the documentation that if you do not have the correct Output config that it will only render silence which is what I am getting currently.
I am convinced that I am missing something in my drivers because I have looked at many vid tutorials and they all seem to have one thing that I don’t and that is the “VST System” option in the Studio Setup and I only have “VST System Link” and that does not carry the same options that I am finding in the tutorial setup.
Thanks again, I will look at the links that you added in your post. Appreciate the help!

Maybe I can’t offer much more help without installing LE to see what’s going on, but…

Can you hear anything at all from your project? It’s all audible until you try to do an offline mix down?

If you can play the project at all, then freezing and mixing down shouldn’t be a problem at all.

If you’re using external instruments (synths, racks, and pedals) and effects, then obviously you’ll have to do some real time mix downs.

Thanks for your response st10ss! Actually, one of the main features of the Cubase Elements 11 app is that it connects seamlessly with external instruments such as the Yamaha MODX8, but I am not having any problems with that. My problem is with the “Audio Mixdown” feature in “Export”. The documentation shows this “The setting of the Output Routing in the corresponding track Inspector determines the channel width of the Export Audio Mixdown export. This means if no main output bus is selected, the exported audio file only contains silence.”
Silence is what I am getting and It seems to be because I cannot route the output due to having only one option “Main Left and Right”. This is why I am saying that my driver configuration possibly needs to be done over, but I am at a loss as to what to change.

Yes, I can hear it just fine. I like to record in midi so that I can manipulate the info and then render to audio. I can mix and record to an audio track in realtime just fine. I cannot use the export feature to do an instant render and it seems to be due to some options that I am missing, which are supported in Elements 11, but I don’t seem to have them.

OK, I might be wrong, but I’m inclined to believe your drivers and devices are fine, and that the error is how things are set before trying to do the Mixdown.

Make sure all of the plugin-instruments involved are routed to a valid output.

When muting/soloing things for a selective mixdown, make sure that the actual plugin-instrument isn’t muted by mistake. Make sure that the master out (or wherever the stuff you intend to mix down is routed) is NOT MUTED. Also, maybe the MIDI track(s) are not muted, but the actual GA instance is…so check that?

If you also have control automation going on for those tracks…make sure they are ‘read’ active before doing the mixdown, or that stuff will be ignored.

You won’t hear anything while the mixdown is being done. Import the audio back into the project, and hopefully you’ll hear anything that was not MUTED or ‘bypassed’ during the mixdown.

So yes, I have checked all the areas of the muted no no’s and still I am having no success. I went back to one of the tutorials and really scrutinized it and outside of the fact that the person teaching is using a mac and cubase pro 11 most everything else is the same, but I did notice that his tutorial focused on one frame of a GA groove. I took the MIDI info out of one track and created a new GA instrument trk then pasted the info into the new trk and now the drum instruments are seen in the mix panel, so I tried the export again and it renders a stereo trk, but still does not separate the parts into the individual trks. Once again, this could be the difference between a Mac vs PC. And so far no one is responding with the same set up as I have so right now it is trial and error. I really do appreciate your effort and thank you for trying to provide a solution!

The" export" should use what you hear, so I guess something is preventing the signal from get calculated(processed).
And this has nothing to do with the driver. If you can hear it, you can export it.
Check if the monitor button for the channel is off, for the export.

That’s entirely different as what you said before.
The mix down on LE can produce a stereo track only.

Appreciate your response, thank you very much!
So let me make sure I understand you. Are you saying that Cubase elements does not have the ability to separate out the GA tracks?

My understanding is that it can. If the performance data is on instrument tracks for GA, simply freeze the track. No need to mix down. It’s in audio form at that point.

If the data is on MIDI tracks pointing to some GA instance somewhere then, you’ll need to mix down.

Mute out anything you do NOT want in the resulting file. Or, solo everything that SHOULD be in the mixdown (don’t forget the actual GA Instances you’re trying to get audio files of should NOT be muted). If you want it ‘dry’ without effects, then bypass those manually as well before doing the mix down.

In Cubase pro, we can select tracks and regions and do an instant ‘render in place’ kind of thing. For LE, you can still render anything you want, but you just need to manually mute out any tracks and instruments that should not be mixed down into the audio file export. Then you import the resulting file back into the project and put it on an audio track.

The export in LE is not able to produce single tracks for every instrument in one go.
You have to do it step by step…

You struggle with restrictions in LE here. I suspect multiple instrument outputs are not possible with LE as well. But I’m not entirely sure.

Thank you Brian, as soon as I get a moment to get back to that I will try your solution! I’m not very familiar with the Freeze aspect of Cubase LE, but I will research it. At the least I may have to bring up multiple instances of the GA and then separate out my tracks that way and render them individually. Of course, that is a hard long way around. Thanks again!

Thanks Steffen for the info. I agree that I am dealing with some limitations, but I’ll make do until I can upgrade to a better version.