Issue with note length using draw tool in Cubase 13

Hi all, first time posting here. I have noticed that when using Cubase’s draw tool in the MIDI editor, the notes ignore the grid and are drawn in very short (as shown in the attached picture). The MIDI quantize button doesn’t work either. This is still happening after deleting preferences and reinstalling the program. Is this a setting that I messed up somehow or perhaps a bug? Thanks
Screenshot 2024-04-27 194316

It would be useful if folks could see your quantize settings.

Can you be more specific about what this means?

This grid is not used for note length. The editor has its own “Length Grid” setting.
grafik
It looks like your Note Length is set to 1/128.

If the start of the note is off the grid than the end of the note will be too.
If you want notes to end on the “normal” quantization grid use this command: