Issue with reverb

Hi all.

I set the same reverb effect for multiple tracks. However when I attempt to record something new, it has reverb but it’s extremely intense. The way I have set the reverb previously isn’t being carried into new recording. Thanks in advance.

Why you are using the reverb as insert? Any special reason for this?

It would be better to use it as “send FX”.

I prefer to use reverb as an insert too. It allows me to apply room reverb and then apply compression / eq etc afterwards to individual instruments and it makes life easier when exporting stems.

Make sure your not putting reverb on your insert channels because you’ll be printing the reverb on audio and then applying more reverb if you’re adding it as an insert on the audio track

But you are aware that this gives never the same results as send FX?

Hi Manike. Thanks for the reply.

What I don’t understand is that you talk about using reverb as an insert, but go on to say don’t put reverb on insert channels. Could you please expand on this? What’s the best way to use reverb as an insert?


If you have an interface like one of Steinberg’s, maybe at recording you are direct monitoring the input channel and what you hear is the reverb of the interface and not the one in your track. If it is not that, then at the moment I don’t know what else could be.

Doesn’t it help if you lower the value of the Mix button? In the screenshot of the roomreverb it is set to 40%. Try somewhere between 15 - 20% if you use it as an insert. The reverb will be less and the original signal will be more.

Oh… was thinking a bit more about it…
did you added the reverb in the input channels by accident?
This will record the inserted plugin…

sorry typo - meant dont put on input channels

Thanks for the advice all. I’ve removed the reverb from my input channels and put reverb into send effects. However I’m having the same issue. Whenever I record something new the reverb is heightened. Is the best way around this just to only edit when all tracks are done?

What interface are you using and, more important, is there any eventual integrated DSP effects in it that could be working under the hood in the audio signal flow ?

So just to reiterate what people are recommending to avoid any possible misunderstandings and to avoid multiple reverbs being in effect for a single track:

  • Add a FX track
  • Add a reverb insert with desired settings to the FX track
  • Remove reverb inserts from all other tracks you want to use the FX track reverb for
  • Add and activate a send to the FX track in the tracks you want to use the FX track reverb for

That was indeed my suspicion above. It sounds strongly to this kind of issue.

If you mute the track where the reverb is, what happens at recording again? If you continue hearing reverb, then the issue doesn’t lay on the reverb FX track and you must search in another place (for example in direct monitoring with the DSP of the interface if you have one of this kind).

there is also a setting with sets initial level for sends

if it is set to 0dB it’s easy to have too much reverb…
I set my default value around -6dB, that fits a lot better for initial reverb settings… but always needs adjustments.

Then we could mention another helpful point with FX… you can select some tracks and by the context menu you can choose “add FX send to selected channels”
this saves a lot of time… it enables the send with it’s default value for all selected channels… very handy…

Thanks all for your replies. I shall play around with this in due course!