[Issue] Zoom when dragging horizontally, not vertically, in

I am having a very frustrating issue where the project or editor window will zoom in or out seemingly randomly when I try and drag the cursor horizontally in the timeline/ time scale. I know that this is supposedly a “feature” when you drag vertically, but it is not supposed to happen when you drag horizontally. I searched this forum but can’t find much about it. How are we supposed to position the cursor if it randomly zooms away from you when you try and move it? Please fix it pronto.

Running Cubase Pro 8.0.5 on OSX 10.10.2

Steps to reliably reproduce on my system.

  1. Grab and drag time scale vertically causing stuttering zooming in or out.
  2. Now grab time scale and drag horizontally this time as if trying to move cursor.
  3. Get extremely frustrated as view zooms all the way out or in again and the cursor moves in opposite direction or doesn’t move at all seemingly dependent on the seismic activity on Jupiter.

I uploaded a video demonstration of the issue. As you can see it is completely erratic and unpredictable behaviour.


It is happens also if I go straight from the editor window to the main project window timeline/time scale then I go to move the cursor and it just zooms all the way out. So annoying.

I have since discovered that this buggy behaviour happens more obviously when you untick the Tansport setting “Zoom while Locating in Time Scale”
As I understand it from previous comments, this setting is not working in 8.0.5 , as in if you untick it you still zoom while locating. But this is further to that, in that it instead creates a very buggy zoom while horizontally dragging.

With this option ticked I still find it zooms while horizontally dragging, but it is more infrequent and when it happens the time cursor does not move away from the mouse cursor. And the time cursor can be simultaneously zoomed and moved as it is supposed to be.

I watched your video, and that I cannot reproduce, either on Mac or Win. Can you please give the details about your machine and what mouse or trackpad you’re using?

I use an Anker desktop mouse, to answer your question - but i don’t think that has anything to do with it, since even in the video you can see that the pointer is not glitching and the clicks are very distinct and fully functioning.

What’s really strange though, is that ever since I reset that Zoom / time scale preference (in the transport settings) the problem has almost entirely gone away. Except for the odd glitch where it zooms a tiny bit before the cursor gets the message again to scrub instead of zoom. But I feel safe using it now, the cursor doesn’t escape from me like before… even if I untick that preference again.

However, it should still be noted that this preference still does not work correctly, in that unticking it doesn’t get stop the zoom drag thing.

Perhaps there was an error in updating my preference file from Cubase 7.5? Or perhaps it is a freak occurrence which happens with only a particular set of preferences. (I fiddled with a lot of settings before finding out it was fixed) Who knows. Come forth anyone with the same issue.

Plus I am still not sure how to get rid of the tiny glitch at the start of the click. It could be a sensitivity thing to the vertical drag. Though I am sure I am only moving horizontally, it could somehow see a minute vertical movement as the mouse is first clicked. However if I do this in a controlled manor, there seems to be a deadzone for vertical movement. That deadzone should prevent what I am experiencing, but it doesn’t.

Steinberg has become embarrassingly terrible at fixing bugs. My zoom has been broken like this ever since moving to 8.5, there are countless videos on youtube showing the issue, yet not thing-1 has been done about it. So over Steinberg, moving to Bitwig.