Issues - Quantizing

I just purchased Dorico, yes w/o trial because I liked Cubase so much, I thought it would be just as good but in notation. Hoping I’m not regretting it.

In the preferences, I set the quantizing to 1/4 notes.

I then began recording.
The midi editor in Dorico didn’t quantize so my imperfections are shows.
When I play it back, the imperfections are played.
The notation shows quantized.

Am I doing something wrong or is Dorico just really buggy?

No, it’s not buggy. There’s more work to be done in the area of MIDI recording to make it smarter, but the current functionality is quite solid. Even though it’s barely two years old, Dorico is the best notation program out there in almost every way.

Have you watched this video? https://youtu.be/42Gmzl7gQ7k

To disable this behavior, go to Preferences > Play and untick ‘Preserve note position’ and ‘Preserve note velocity’. To fix what you’ve already recorded, select the music, go to Play mode, and use Play > Reset Playback Overrides.

1 Like

There are two basic use cases for MIDI recording (and there’s no way Dorico can know in advance which sort of user you are):

  1. “I use MIDI recording just a means of entering notes into the score”
  2. “I want Dorico to play back my score exactly as I recorded it”

The default is (currently) number 2. If you toggle the preference that Anders describes then it puts it into the first mode. However, Dorico still remembers the original timing of the notes that you played so that you can select a range of notes and re-quantize them to a different unit with Edit -> Requantize.

Thanks a lot, I have Dorico 3.5 trial and was wondering about quantization before buying 4.0 :slight_smile: