Issues setting up midi mapping with my Kenton Control Freak controller

I’m trying to map my Kenton Control Freak (16 buttons and 16 sliders) to control mixer channel mutes and volumes. Been having a bit of a nightmare, so just trying to work on the buttons to control mutes to start with, but even so I’m not getting anywhere. Any help would be appreciated!

So I’ve mapped 16 buttons in Cubase 12 Artist’s midi remote manager. When I tap the buttons, I see them light up in blue in the mapping assistant. However, after I map them to channel mutes, nothing actually works.
I’ve tried mapping to channel mute in 3 different ways and messed around with toggle vs jump (see video) , but nothing works.
Any thoughts on what I’m missing here?



(edit: addition - Should channel mutes be cc120, not cc7? Currently my channel mute buttons and channel faders both show CC 7 if I add them into remote manager.)


Could you show the Assignment to Cubase function (the right panel of the Assistant), please?

1 Like

Hi Dan,

Did you close the mapping editor?
It needs to be closed, to make the changes and mappings work.

1 Like

Thanks for your reply and help.

The view in the function browser (that’s the only panel to the right of the Assistant to me - is that the same thing?) is odd in that it doesn’t seem to update when I press the different buttons.

ie - mute channel 1 - shows channel 1 and mute on the function browser. Press the button to mute channels two and 3 - it stays on mute channel 1 in the function browser. Then I go to mute channel 5 and the function browser updates properly.

I think u-man’s note about closing everything down has fixed the ‘totally not working’ issue (see post below this one) - but I’m still trying to deal with having to double press and having issues mapping both channel mutes on buttons and channel volume changes via faders. If you see anything to do with those issues in the pics below, I’d be grateful if you could tell me what I’m doing wrong!


Hello and thanks for your help.
Crazy, but that was a big part of the issue! I closed everything down - even Cubase itself, then restarted it and the buttons worked. Thank you.

The funny thing is, the buttons only work on the second press - when the button is essentially sending out ‘unmute’ (or 'reset)… essentially the button is toggling on the reset only. Any way to fix that?

I loaded up Midi Yoke to capture what was happening during the button presses, just in case it’s of some help:



Good point! Did you do this?


It’s all in the replies above!


Then the button obviously sends values 0 and 127 and your setup accept only the 127 value. Change the settings, please.

1 Like

This screenshot has a bit weird logging.
Initially your first button sends to channel 0, volume 0. Upon release, it sends volume 0x18. No problem so far, as @Martin.Jirsak this means you have to change your value range to the MR.
However, the third time you press this button, we now see a value 0f 0x17 NOT a zero. Then based on the timestamp, we then see a decrement to 0x16 and afterwards to 0x15.
At the same time on channel 2 everything works OK.
Could you please provide another screenshot with just the button 1 pressed and released immediately (OK, after some milliseconds that is, as we normally click buttons) for a few times and post it here?


Thanks for your thoughts.

I’ve been testing a few things and think it’s because of the fader on the same channel.

Just pressing button 1 gives this:
Pressing Button 1

However, I pressed button 1, then moved fader 1 and then pressed button 1 again. It seems the button value on a press is linked to the fader value. This relates to the problem I have in MR in that I cannot set up the mute buttons and fader volumes - they seem to be using the same cc values.

Pressing button 1 then moving fader 1 then pressing button 1

I’m really just exploring midi and cubase as a bit of a newbie. I mentioned this already, but are mutes always on cc7, or should they be on another cc, like 120? Seems both volume fader and mute are on the same cc so i can understand why they would interfere with each other.

Then the button obviously sends values 0 and 127 and your setup accept only the 127 value. Change the settings, please.

Issues are linked? I’ll check the values.
(edit - the values are as you see in the Mapping assistant photos above … 0% and %100.
If there is any way to change these to fixed 0 and 127, please tell me as I have no idea how!)

Based on the manual of this controller, you can change the midi CCs sent from it.

You first have to check which CCs is everything sending, and since there are conflicts, change the CCs of the buttons to other numbers, for e.g. 21 to 28 (0x15->0x1C) and to a value range 0 to 127 (0x00->0x7F).

Here’s a link for the manual which shows the edit procedure:

1 Like

@mchantzi Ok, that’s great. Thank you! From your post I’m assuming that I can just change the mute on/off cc’s to any number, especially those that are unassigned? I always thought that volume changes HAD to be on cc7.

If not then, yes, it’d be relatively easy for me to create a new profile where the button presses for mutes are on cc21 and the volume faders remain on cc7.


With MIDI Remote (or any kind of modern assignment) you can sign any MIDI CC to any parameter.

1 Like

Thanks for the confirmation. Makes sorting the mute/volume issue much easier!