Issues with Midi Sync: Cubase as Master to (SP1200) external device

Since Steinberg email support seems to ignore requests ( Ref.#02044236ref:_00D30F1z._5000MlsZNT:ref)

I’ve been having issues acurately syncing an E-Mu SP1200 to Cubase 9.0. Cubase triggers the device and it stays pretty close in sync but if I try and cut/paste a bar of music from later in the song the audio events are slightly off and I end up having to manually align them to match the reference audio underneath (like snare or kick). Hoping someone can take a look at my settings (attached png) and tell me if you can see any reason why this would be and how to fix?

I even got a E-RM Multiclock to try to solve this issue but we discovered both the clock and Cubase were running almost perfectly in time but the SP1200 was not the longer the recording continued. Here’s video of my experiment showing the recorded Multiclock click and SP1200 metronome against the Cubase metronome:

I also read a thread about “system timestamp” and “enableemulated” files. I have no idea what they do but thought I’d bring this up to get your feedback as well. below are my sync settings and midi port set-up.


I would use Internal Timecode on the Cubase side.

Thx will try that! Could it be that simple?