Issues with Note Performer 3

Hi guys…Ive been experiencing some issues with Note Performer 3 & Dorico.
Here’s my issue… at the end of the orchestration, I decided to add 2 new instruments (timpani and clash cymbals) but they are not uploading to the #2 NotePerformer3 mixer empty channels 14-15…as I thought they should.
As a solution, I had to use a timpani and a clash cymbals from Aria Player library instead, but I’d like to know if it’s possible to add new instruments to the orchestra once the first set up of Note Performer 3 instruments were done.
I was wondering if this could be happening because I’m using other sound libraries (Kontakt, Aria Player, Halion) in addition to Note Performer 3?

Here’s Note Performer 3 customer service representative response:
"<Hi Mike
To be perfectly honest, I’m not sure how Dorico reacts to having multiple libraries loaded. A problem like this would normally be resolved by re-applying the playback template from the Play->Playback Template dialog.
You cannot assign sounds manually to a MIDI channel in NotePerformer. Reason is, Dorico handles the patch management. And I don’t think Dorico (currently) sends the patch each time you playback, but only when the staff is created (or template is assigned). So you must find a way to make it work without assigning MIDI channels manually, and normally the instrument should automatically be assigned to the device of the score’s playback template.
You may have already tried the Dorico forum, but Daniel and Paul at Steinberg have a more complete understanding of how Dorico handles multiple devices at once. ">

Any idea of what’s going on?

Thanks for your time and help in advance
Best regards
Mike

Have you tried re-applying the playback template as they suggested? Was it unsuccessful?

Arne has also suggested to me at least once that if things get out of sync sometimes it actually helps to re-start the computer…

  • D.D.

Reload the note performer template.

Hi guys…thanks for your prompt response. ( DaddyO / robjohn9999 / Andre )
Yes, I have tried your suggestions DaddyO & Andre …it did not work!
And also robjohn9999 I re-started the computer. Nothing happened.
As you can see on attachment 1, channels 14-15 are still empty. Note Performer 3 doesn’t load the timpani and the clash cymbals as it should.
The channels have been properly assigned to channels 14-15 Mixer2 (see attachment 2)
I have come to think if the problem could be that as in my preferences of Dorico Note Performer3 is the default playback template, because I am using other libraries simultaneously it could caused a conflict … what do you guys think? (see attachment 3)
This is weird isn’t it? not to mention kind of frustrating because Wallander Instruments customer service have no idea of what’s going on and /or how to solve the issue.
So far, I do not know if the problem is with Note Performer 3, Dorico or both.
The only thing that occurs to me to try would be, (Play mode) deleting the NP3 Mixers (all of them) and reload them again…but I’m not sure…I’m afraid that if I do this, maybe NP 3 would not be able to load back again the previously assigned sounds and I’d lose all my work. At least using the option of Aria Player and Kontakt I have the sound I want…but it’s not supposed to be like that
Thanks again for your help
Best regards
Mike



Hmm. I admit that when using Noteperformer I do not try to mix it with other libraries.

Hopefully someone can help you figure it out. If I knew how to approach it I would do so.

I had the same kind of problems when I tried to mix libraries, NP started to act up and didn’t want to play back anymore.Here is the post:
https://www.steinberg.net/forums/viewtopic.php?f=246&t=139251&p=750202#p750202

You cannot currently mix NotePerformer with other libraries. The reason for this is that Dorico Playback Templates are ‘all or nothing’. If you use a playback template then you are asking Dorico to create instances of the plugin and send the correct program changes or HALion preset load commands so that the plugin loads all the correct plugin patches for your project. However if you manually change the routing of any instrument in Dorico, or add a new VST plugin to the rack then Dorico can no longer manage this automatic loading (it has no way of knowing what you want to happen), so it switches into ‘manual’ mode. The intention is that if you start changing anything then Dorico won’t overwrite your changes.

NP is intended to work in that ‘fully slaved’ mode where it relies on the application to tell it which patches you want. It doesn’t currently have any UI where you can specify this yourself. Dorico doesn’t currently have the ability to send custom bank and program changes for each instrument, which means that there’s no way presently of changing the patches that NotePerformer loads.

These are all things on our roadmap for the future.

Hi Paul and Andre…thanks…I was suspecting that using other libraries could be the problem. Now you confirm it.
Then the solution would be to delete the other libraries and work only with NP3?
Thanks again
Mike

Unload them in Play mode (no need to delete them from your computer) and then load the NP template.

No need to unload, just apply the NP template, which will set up the VST rack with only the required instances of NP

Ok…thank you guys
Best regards
Mike

Hi Andre and Paul… thanks again for your suggestions.
I applied the NP3 template and everything loads perfectly.
However I’ve lost a couple of instruments that NP3 library doesn’t bring and that I was using on this orchestration, such as an Hindu Tabla and a Synth pad with Kontakt 5.
I was wondering how do you guys will solve a situation like this,considering that NP3 doesn’t work with other libraries.
I was hoping that I wouldn’t have to go to Cubase to edit the whole score (the score sounds very decent actually) but I don’t see any other option. Any suggestion would be much appreciated.

By the way I’d like to get rid of some bars or measures, at the end of the work (pleasse see attachment) that I don’t need. The last one should be bar 150, so I’d like to delete the following bars from 151 to 171.
How could I do this?
Thanks again for your time and kind help.
Best regards
Mike

Once you have all your instruments loaded in NP, I find that I can load some of those to other virtual instruments and so far I did not have any problem. I’m using pianoteq 6 quite often along with NP3 and so far everything goes well.

Hey Marc good to hear from you
Thanks…Good news…Uhmm that’s the trick!
Ok I’m going to try it
Thanks
Mike

In the future we hope to extend the playback template mechanism to allow you to mix and match between multiple plugins and specify your own preferences, eg ‘all instruments played with NP apart from tablas which will be played by plugin X’. Marc’s suggestion should work for you in the meantime.

Thank you Paul…that would be great!
Yes Marc suggestion works!
Thanks again
Mike

Hi Paul…I forgot to ask you…do you know how could I get rid of these unwanted bars? (please see attachment)
The last bar (finale) should be #150. I want to delete the rest of them from #151 -171.
I know how to delete unwanted staves or player but I couldn’t find the way to delete these unwanted bars.
Thanks for your tme and help in advance
Best regards
Mike

In Write mode, select any object in the flow, and choose from the menu Write > Trim Flow.

Hi PjotrB thanks for your tip…well. it definitely trimmed some bars (from 158-171) but not the rest of them. I still have unwanted bars from 151-158. I’m doing the same procedure but it doesn’t work. (Please see attachment) Any ideas of what am I doing wrong?
Thanks again
Mike