It's annoying how ctrl+x cutting deselects multiple tracks (when track selection follows event selection is on)


It doesn’t work to me here, as it is in your video.

maybe if in a folder?

I’m on 10.0.4, maybe it’s fixed in 10.5?


I have tried in the folder. And you are right, I have tried in Cubase 10.5.

Thank you,
I don’t know if this is considered a bug.


I have just tried to reproduce it on Windows (the tracks are in the folder). I can’t reproduce it here neither. All 3 tracks remains selected after Ctrl+X.

perhaps it is performance based? maybe try increasing your latency?

just to clarify, you have the preference set on correct? ‘Track Selection Follows Event Selection’ needs to be on for this problem to occur for me.


Oh, I’m sorry, I overlooked this. Now I can reproduce it. Btw, funny part is, the very 1st of selected track remains selected on my side. On your side, the last of the selected tracks remain selected.

That’s my fault for putting it in the title and not explaining in the OP.