Jagged cc controller curve

Hello everybody

Trying to use a Presonus Faderport as a midi controler and I’m only missing the last step. The problem is that the faderport only sends volume automation data, whereas I want it to control cc1, or cc11 or whatever cc I want. I’ve managed to set it up this way with help of midiloop and the Generic remote control. However the recorded data seems to be missing some of the information. The result from a smooth controler curve is a jagged one that’s considerably less refined.

Here’s the curve transmitted:

And here’s the cc info I get:

As you can see I managed to transform the volume automation to cc1, but the result is a jagged line instead of a smooth curve. I’d be greatful on any help on this. I already tried to disable grid and quantizing to no avail. Is there a setting for the controller lane that connects two points directly instead of the nasty steps I’m getting?
Thanks in advance for any help



Thanks for the help, but sorry, I seem to be a bit inept. Where can I set the recording resolution? The only thing I found in the manual was about bit resolution (16 vs 24). And I only found a switch between linear and steps on the tempo track, but not for the controller lane. I’d appreciate it if you could tell me (sorry, obviously a noob) where to find these settings you were reffering to

He may have meant “Reduction”, which is an automatic “thinning out” of the data points. My guess was to turn off the snap or make the grid smaller but you said you already tried that. I would still try lowering (or raising?) the reduction.