Jamstix in Cubase 6

Do any of you use Jamstix 3 in Cubase 6. In Cubase 5 I would just load up Jamstix in an instrument channel and use the downmix function in the Jamstix mixer to send everything to the first stereo output pair. Since upgrading to Cubase 6 this down mix function no longer works, everything but the kick drums only come out as mono in the left channel.

Ive tried explaining it to the dev but I suspect he thinks Im an idiot (could be right), he asks have I activated all the Jamstix outputs, I reply I shouldnt have to as Ive loaded it in to an instrument channeland down mixing at which point the correspondence stops.

I dont think its a Jamstix problem as it all works fine in other hosts

Maybe I am being an idiot and it never worked in an instrument channel in C5.


Yes - I use in in C6 (now C6.5) without a problem. I don’t have it set up the same as you though. So a couple of questions.

Are you using the Instrument Rack, or are you using an Instrument Track?

In the options tab, is “Stereo Outputs” selected?


Hi Ron

Yes Im using an instrument track, and in the options stereo output is selected.
I can also put it in the rack but if I only activate the first output and down mix in JS then snares only come out the left channel same as it does when in an instrument track


Are the snares (and other kit pieces) panned left in the Jamstix mixer?

I just created a new project. Added one Instrument Track with Jamstix 3.3.8. I used the wizard to load a song, and loaded "Funky Song - Chad.j2d. Played and only got the Kick (as it was the only instrument assigned to channel 1). Turned on downmix. Got all the drums full stereo.

I think Jaslan might be on to something. The panning is not done in the mixer, however. Instead its done on a kit piece basis.


Ok then I followed those exact same steps. I get everything hard panned to the left apart from the kick. Only channel one shows kick activity and channel 2 has everything else as attached pic.

In the Kit the snare is panned centre

Also when I do the same thing in FLStudio all the outputs show activity in the mixers level meters

Are you using the 32-bit version or the 64-bit version of Cubase?

Also what happens when you use your mouse a click a cymbal, which by default is assigned to channel 5. It should show up on channel 1. Does it show up left only on channel 1?

If you turn off downmix, You will lose the parts assigned to channels 2-4, and get kick and cymbals. As above, are the cymbals left channel only?

Also with downmix turned off, you won’t be able to hear ch 2-4, but you can still see them. Are they Left only? (i.e. is it really a downmix issue or something else)


Edit - I am using JBridge to bridge 32-bit to 64-bit, so I thought that might have something to do with it. So I removed the JBridging, but there was no change. Everything still works as expected.

On the surface this does not seem like a Cubase issue, but JS3 issue, because you are seeing the right channel missing in the internal JS mixer. So the question is why would it work in your other host? Try the things above and let me know.

Also - I tried to find your post on the rayzoon forum - could you point me to it? Usually Ralph is very responsive.

Hi Ron, checked that. I made a mistake in my earlier post as the Cymbals are down mixed fine. Cymbals on output 5 and side stick on output 6 both get down mixed correctly. Everything on outputs 2 3 and 4 snare hats and toms as left channel only. So whatever outputs I have set up in options in this case 4 are being downmixed in mono, eveverything on the other outputs is downmixed correctly. Its like they are being downmixed to output as mono to the second output before being sent to the first output channel.

When I turn off down mix I get kicks an cymbals

Im running Cubase as 32 bit on W7 64bit

I emailed Ralph at support, late last year I think, I am trying him again

When you turn off downmix, visually what happens on ch 2-4?


All four outputs show stereo activity

Hmm. The does point back to the downmix. Which version of Cubase are you using? As I said, I’m on 6.5.1.

There is an option labeled “Never Downmix” I’m assuming you have it turned off. Only other things I can think of trying (and it this point I’m shooting in the dark)

Kit tab - drop down (just below song tab) "Reset Virtial Kit (have no idea what it does and couldn’t find it in the manual)
Try changing your number of outputs to 8 (maybe that will “reset” something and get it working). If so the you can put it back to 4 if you want.

BTW - A quick work-around (but not a fix) would be to change the number of outputs to 1. You would lose mixer capability though. The other option would be to use the Instrument rack without downmix and use the cubase mixer instead.


Yeah its a bit of a mystery. Ive emailed Ralph again ,hopefully explained it better, maybe he will shed somelight on it.

Anyway thanks a lot for spending some time on looking its appreciated.