jBridge not working with Cubase 7 64 / Win 7 64

I just recently purchased Cubase 7 and have gotten the 64bit version installed on Windows 7 64. I haven’t used Cubase since version 2.1 so it’s been a while. I have several 32bit plugins that I want to use and found jBridger, which seems to be what several people are using in this situation. Unfortunately, for the life of me I cannot get Cubase 7 to recognize the jBridge folder with the converted 32bit plugins. I don’t know what I’m missing. I followed all of the steps and have looked online for a solution, but I cannot seem to find one. Also, I should say that I am using the trial of jBridger because I wanted to be sure it worked before I bought it. Can someone tell me what it is that I am doing wrong?

Here’s what I’ve done:
opened jBridger, selected 64bit host, selected only to convert 32bit plugins, opted not to add .32 or .64 to file name, specified my own file folder, and converted the files

(I’ve made sure too that all the auxhost.exe files and the jbridger.exe file has the properties set to run as admin)

Opened Cubase and gone to devices > plug-in information > clicked on the VST-plugins tab, selected 2.x VST Plug-in Paths > clicked on add, found the folder I made with my bridged 32bit plugins, hit okay. I then clicked on the Update Plug-in Information…nothing happens. I click on just the Update button…nothing happens. The button highlights blue, but does nothing. It’s like Cubase isn’t responding to me pressing the button.

If I save and exit and reopen the project then the VST folder I selected previously with my bridged files is no longer listed in the plug-in path.

I don’t get it. What am I missing?

Not sure what it is, but I have better luck with the native bridger in C7, and better luck with JBridge in C6.5.

do you know what version plugin’s they are ?

I think most are version 2, but then there are some that I am not sure about like my Camel Audio Chameleon and dBlue Glitch plugins. I know this sounds like a stupid question, but how do you find out exactly what version of VST it is?

for what its worth…im using Win 7 64 and Cub 7 64 and Jbridge… and it saw my jbridge folder. C7 scanned it upon restart.

are you using some tricky symbols in your folder name? stick to letters only man…no _ or - or %^&*.

I had the folder just named “Bridged 32bit VSTs” and I changed it to “Bridged VSTs” but it made no difference. I know it said it wasn’t recommended, but I placed the bridged folder inside the Steinberg VST folder. When I restarted C7 crashed and it said the bridger64.dll file was to blame. So I cut the folder and pasted it just outside the Steinberg VSTplugins folder and tried to point C7 to the folder again, but it still will not update. This is just really frustrating.

I would start again with the setting up of jBridge and use this path which works here: C:\Program Files\Steinberg\My jBridgedPlugins
You can use a different name for the bridged plugins, of course.

BTW, where are your 32bit plugs located?


I pointed my Steinberg VSTplugins folder under my Programs (x86) folder and my 32bit plugins seem to be working. So it looks like just the native VSTbridge is working and it’s jBridger that won’t work for whatever reason. I’ll take it. I just don’t want to lose my plugins. Thanks for all of the help.

Are you running Cubase 7 as an administrator? That’s a very important and necessary step, without which jBridge simply won’t work. Mine works fine. I keep my jbridged VST’s in a folder called “jbridged VSTs” residing on the root of the c: drive.

Another important thing: your 32-bit VST’s should NOT be located in the standard folder Cubase uses, but they need to be in a subfolder inside Program Files (x86). For the record, mine is called “32bit VSTs.” Cubase should NOT be able to access that folder or conflicts between jBridge and VSTbridge may occur, resulting in Cubase crashing.

Incidentally, jBridge still works way better than Cubase’s own VSTbridge. There are some very old VST’s I still use that jBridge manages fine but VSTbridge can’t handle without crashing Cubase. One example: the old Ueberschall Liquid Player. I don’t use it often, but since I own virtually all the libraries (which cost me something like $2,000 back then) I don’t want to lose it.