JBridged plugins.

Will JBridged plugins still work in C9?

Here they do! Others report success as well…
B.

Make sure you download the latest Jbridge, otherwise there are issues.

Z

if it`s an older jbridge rightclick the app in program files and select properties/compatability tab/tick-run this program as administrator ,do the same with cubase 9.

the old SX3 delay and reverb and rotary wont work with jbridge im cheesed off about that i love them plugs.

FYI, the jBridge developer has just posted a new 1.75 beta which disables the “run as an admin” warning for better compatibility with Cubase 9. If you are a registered user, you can request it here:

https://jstuff.wordpress.com/jbridge/beta_updates/